Not able to bootstrap from the excel

Not able to bootstrap from the excel

Hello Community,

I have started using service studio version 9 one month before. I am doing bootstrap from the excel using advanced option of entities. 

When I select excel for bootstrap, it is desired that excel values must come into the entity but this is not working.

Here I am attaching my entity design and excel values. 

Please advice because this is most embarrassing behaviour I observed today.

Suraj Borade
Are you able to provide the exact excel file?  I'll try and boot strap it.
Hi TravTrax,

Thanks for the reply. 

Please find the attached excel file I am using to bootstrap.
Hi Suraj,

It worked flawlessly for me.
  • I created a new test app.
  • Created an entity called AboutMySelf
  • Created three attributes matching yours (no changes to attribute type:text or length:50)
  • I right-clicked on the AboutMySelf entity and used the Advanced->Update Action to Bootstrap Data from Excel
  • Saw the pop-up showing me the association of columns with attributes which I confirmed.
  • Saw a bunch of stars...
  • Created a list screen and linked it to the AboutMySelf entity
  • Published
  • Launched - successfully showing the records from the excel
Check your logfiles and also check that you confirmed the import association of columns to attributes.

Did you receive any errors?


Hi TravTrax,

Thanks for taking efforts for me.

I deleted my entity and created new one and bootstrapped with the excel. Now excel data has come into the entity.
I don't know what was the problem. I lost old data and now I have only excel data in an entity. Is there anyhing like we can't import from excel if old data is there in the entity? This behaviour is not acceptable. We should be able to import from the excel at any stage.
I actually attempted to import the same excel data twice, but it didn't save any duplicates on the second attempt.

I just went and tried to import new excel data, same file name, and it looked exactly like the previous import but when I loaded up the list screen in a browser, it did not contain the new data.

I even tried by changing the file name, just in case, and tried again.  No luck.

I think "bootstrap" means, pre-populate for the very first time.
Hi TravTrax,

Even I think the same. We must report it to the OutSystems because just now I created two entiies. I bootstrapped one with excel values and able to see values in List page. I inserted values in other entity using the browser. Now I am not able to bootstrap that second entity.
Hi Suraj,

It's actually the default behavior of the auto-generated bootstrap action.

Adding a bootstrap will:
- add entity (unless it already existed already)
- add the excel file as a resource
- add a timer that will run every time the module is published
- add the action that will be associated with the timer

Check the generated action that is doing the bootstrap.
At the beginning there is a condition to check if the entity is empty and skips the bootstrap otherwise (since it has data it was already "bootstrapped".

You can change the auto-generated logic to do anything you want, but dont forget that the action is set to run everytime you publish the module.

João Rosado
Hi Joao,

Thanks for the explanation.

Actually I was aware about bootstrap timer when we publish but I wanted to bootstrap from the excel. Now I got that manually I can bootstrap from the excel only if entity is empty else I will have to use bootstrap timer to get excel values into the entity.

Thanks a lot.