Image is not displayed in email sent with RichMail

Image is not displayed in email sent with RichMail

  
Hello
 
I'm generating an email using RichMail and I'm doing the following steps:
- I've create a web screen with my email content. That web screen as an image static, located in the images folder of the same eSpace.
- In the action to send the email, I use the extension HttpBinaryGet and then the action BinaryDataToText to obtain the html content.
Debugging, I can see that the image source is in the html <img alt="" src="/eSpaceName/img/EmailLogo.jpg?108042" height="50" width="100" />.
- I use the methods RichMailCreate and RichMailSend, to create and send the email.
- When I open the email, the image is not there. In the email html I only have: <img alt height="50" width="100">. No image source.
 
Do you have any clue why is this happening?

Thanks
Hi R,

What do you want to achieve with the e-mail: 1) actually include the images with the e-mail, to be displayed without access to the original URL or 2) link from the e-mail to the images, which means the receiver must have access to the original URL.
Hello Kilian

I want to achieve 1) actually include the images with the e-mail, to be displayed without access to the original URL.
It's just an image to be in the email header.

Regards

Right. In that case, you need to set the "InlineImages" parameter of RichMailCreate to True. Specify the image's src relative to the eSpace (so use e.g. "img/MyImage.jpg") and RichMailCreate will take care of the rest.

EDIT: It's probably also no problem specifying an absolute URL instead of a relative one, but if the image is included in the eSpace, it's better to use a relative path.
Hi Kilian

Thanks for your response. I think I'm doing everything ok. I attach a sample eSpace. Please check the screen action "SendEmail".
The email is being sent but it is only displayed the text, not the image.
Perhaps the image is being blocked by the email server or the email client?
Hi R,

The one thing that's missing, and that I forgot to mention on account of me not recalling this was needed, is the Url parameter. I have hounestly no idea why it is needed (the RichMail help file is broken), but I fill it with the local URL of the eSpace ("http://127.0.0.1/eSpaceName/"), though the absolute URL may also work ("http://myServer/eSpaceName/").
Hi Killian

In fact, filling the image url with 

 

"http://myServer/eSpaceName/img/ImageName" works! :)
Problem solved.

Thanks a lot