'BasicTypeList

  
While doing the full publish the following error comes. Can anyone suggest on what can be the issue :

Compiling eSpace Compiling 'om_e_smb'.
Internal Error The 'BasicTypeList<Integer>' name is already in use.  

What are you publishing, a full solution? Are you doing it via Service Center or LifeTime? What causes the error? An eSpace? An extension? You are providing us with way too little information for an answer.
Sorry for the insufficiency of info.
I am getting the error given below for both the scenarion

1. A full solution is being published via Service Center. 2. Lifetime .

This is everytime after a perticular espace (Example :Util eSpace) .How to track why this error is coming?

Module:
CompilerService
Message:
The 'BasicTypeList<Integer>' name is already in use.
Environment Information  
Stack:
Exception Details:
[1] Internal Error: The 'BasicTypeList<Integer>' name is already in use.
   at outsystems.runtimecommon.HEMessageException.<init>(Unknown Source)
   at outsystems.hubedition.compiler.utils.IIIIiiiiiIIiiI.$hxf(Unknown Source)
   at outsystems.hubedition.compiler.utils.IIIIiiiiiIIiiI.$lpf(Unknown Source)
   at outsystems.hubedition.compiler.ESpace.afterLoad(Unknown Source)
   at outsystems.hubedition.compiler.ESpace.<init>(Unknown Source)
   at outsystems.hubedition.compiler.Compiler.innerCompile(Unknown Source)
   at outsystems.hubedition.compiler.Compiler.compile(Unknown Source)
   at outsystems.hubedition.compiler.Compiler.$abl(Unknown Source)
   at outsystems.hubedition.compiler.iiiiIiiiiIIiII.executeImpl(Unknown Source)
   at outsystems.hubedition.util.delegates.Action$Action0.execute(Unknown Source)
   at outsystems.hubedition.compiler.utils.CompilerUtils.withOverridenSettings(Unknown Source)
   at outsystems.hubedition.compiler.IiiiiiiiiiIiii.executeImpl(Unknown Source)
   at outsystems.hubedition.util.delegates.Action$Action0.execute(Unknown Source)
   at outsystems.hubedition.util.delegates.ThreadStart.run(Unknown Source)
   at java.lang.Thread.run(Thread.java:682)


Regards
Ankit


Do you also get this error when manually publishing the affected eSpace? Or only when publishing a full solution?
No I do not get this error when I pubish the espace manually. I get the error only when I do a full sollution publish and lifetime move from one environment to other.
That is decidedly weird. Have you contacted OutSystems support about this? It may be a platform bug.
This same problem occured for me too. Unable to deploy the eSpace using lifetime.

03-10-2015 10:54:35 The 'BasicTypeList<int>' name is already in use.

With service studio the publish to the next staging environment went through fine.
I also experience this error with a particular espace when:
  1. Deploying my application over to another environment using LifeTime
  2. Publishing my application via ServiceCenter
Strangely, I am able to publish that espace via ServiceCenter or ServiceStudio.

This is my workaround:
I changed the input parameter of public method from <List of User Identifier> to <List of Integer>.
Tata! I am able to deploy via LifeTime and ServiceCenter after this.

Apparently having <List of EntityRefInteger> as parameter in a public method causes this error. Try using <List of Integer> instead. You can still convert it back using IntegerToEntityRefInteger after that.
Seems like a platform bug to me.

Hope this helps :)

Running on Outsystems Platform Version 9.0.1.25

Same error here. On platform 9.0.1.15, Lifetime or SC.

When publishing via Studio (9.0.1.60) the problem doesn't occur.

Pretty sure I reported this as a bug ages ago.


J.Ja

Same error here on 9.0.1.40

Hello,

This problem was already fixed in the versions 9.0.1.50 and 9.1.0.20 (Platform Server .NET and Java).

The bug caused two different types in OutSystems (for example, Integer List and User Identifier List) to be translated to the same underlying type (in this case List<int>), resulting in a compilation error as you've seen. The error would occur when compiling a Solution or Application. If you publish the eSpace alone, it should not happen.

You can avoid the problem by using a Record List instead of List for the OutSystems type.

I hope this information can help you overcome the problem.

Thanks Cláudia, that's informative, and good news :).

Great news... Thanks

They aren't planning to upgrade here for a few weeks yet and I don't want to wait that long. Is there any way to *search* for List of <AnyKindOfIdentifier>? I've been over the processes, interface screen methods, actions and web services with what I thought was a fine-toothed comb, but I'm still getting the error.

Regards,

-- Ritchie

Hi Ritchie,

There's no one way to search for that. I take it you have a huuuuge eSpace that you can't find the problem?

Hi Ritchie,

As Kilian says, there's no way to search for that exact pattern, but a possible approach is to go through each Entity of the module (references included) and use Find Usages (F12). Then sort the results list by Property, and look for the uses in properties named Data Type.

It's not perfect, but hopefully it can help narrow down your search.

Cheers,

Paulo

I'll try that, Paulo. Obrigado :)

-- Ritchie

No luck with that either, though it did make a good double-check for my previous manual checks. I had already converted my List of <x> Identifier over to List of Integer.

I'm starting to wonder if there are leftover artifacts somewhere.

I'd suspect an extension, but you can't actually use lists of identifiers with extensions; it's all record lists.

*confused*

Is there an equivalent of "Build->Clean Solution" somewhere? :)

Since it occurs only when publishing an entire solution, I think you'll have to use the workaround of publishing the eSpace manually.