Could not establish a secure connection Service Studio


I am getting below error while connecting my outsystem Environment from service studio 9.0

Could not establish a secure connection with "x.x.x.32" (My Server IP)
Either the "Server IP" does not support secure connections or has an invalid certificate

Can any one help its very urgent
Hello Kamlesh,

Sorry for the late reply. Not sure if you already solved this problem, but usually Service Studio (aka Developemnt Environment) attempts to connect via HTTPS and then falls back to HTTP if it fails.

The fact that the error in HTTPS is being shown, then suggest that it couldn't connect either way.

Are you using a proxy to connect to the server?


Thanks for reply.. we have resolved this issue by restarting application server. 

Thanks once again. 
We had the same issue in version 9.1.401 today.
Restarting only the ServiceCenter app pool solved the issue.

We also had this issue "Could not establish a secure connection". Eventually found out it was the issue with invalid/mismatched self-signed certificate.

Removed the server certificate and issued again with SAN. Later trusted the certificates and issue gone.