[Offline Apps] Offline photo capturing with an offline application

[Offline Apps] Offline photo capturing with an offline application

Forge Component
Published on 2015-11-19 by OutSystems Labs
25 votes
Published on 2015-11-19 by OutSystems Labs


I'm not able to get offline photo capturing working with an offline mobile application I'm working on.I’ve tried to use the same logic as it was done in Inspections application (available on the Forge) the only difference is that I’m using the newer Offline images wedlock from the Offline Apps application.

Could you please help me understanding why the photo capturing is not working?

In attachment follows the OML file that I’m using, please let me know if you need more information to analyse this.



Luís Luciano


There were two simple mistakes in your OflinePatrolDetail screen:
  1. An input was called OfflinePhotos_PhotoBase64 when it should be OfflinePhoto_PhotoBase64
  2. The offline extended property on your images has the value OfflinePhotos.PhotoBase64 when it should be OfflinePhoto.PhotoBase64
After fixing these the application is OK, as far as I can tell. I've attached the changed eSpace to this post.

That being said, I've noticed there's a bug that we had already fixed in our development environment but was pending release, that might affect your application. I've released a new version of Offline Apps with that fix.
Omg, thanks João for finding those mistakes, after correcting the app works great, I also upgraded to the newest version of the Offline Apps application from the forge to get the updates you mentions. Thanks again!