Serious error in upgrade from 9.0 to 9.1 (no app anymore)

Serious error in upgrade from 9.0 to 9.1 (no app anymore)

  
I've made the wrong decision to upgrade the server from 9.0 to 9.1. Everything was fine...

After that I got a 404!
 
Is it normal an that an upgrade undeploys the app?
So I downloaded Service Studio 9.1 and tried to redeployed it.

Now I get this error which prevents me from upgranding/redeploying :(


Basically, I'm in a deadlock.
 
Full stack trace: http://pastebin.com/Dsqb7n6n
 
Please can you help me? Thanks and BR
Hi Luís!

It looks like there was a name clash problem with your eSpace. We already identified the root cause and is marked to be solved in the next version.

The problem was mainly one action called: TextToIdentifier that's a System Function in the new Bali version. Renaming it was enought to solve the problem.

That should be enough for you to continue do develop and use your Personal!

Hi David But couldn't that be prevented by using namespaces? I mean... Each set of functions would reside in a namespace (conceptually speaking and not technically).. And then you wouldn't have anymore name conflicts. Thx & BR