[Event System] OS v9.1

[Event System] OS v9.1

  
Forge Component
(19)
Published on 1 Nov by Leonardo Fernandes
19 votes
Published on 1 Nov by Leonardo Fernandes
Hi Leonardo,

I've stuffed up and had our environment upgraded to v9.1 thinking I'd seen a 9.1 upgrade to your component, must need new glasses, fortunately only the development environment so far.

The events system is broken with the following error appearing when called...

Method 'Log' in type 'OutSystems.NssEventSystem.Events.SideEffects.ScreenLoggerInterceptor' from assembly 'OutSystems.NssEventSystem, Version=9.0.1.25, Culture=neutral, PublicKeyToken=null' does not have an implementation.

What are your plans for v9.1 support.

Cheers,
Gavin
Hi Gavin, Version 9.1 is fairly recent so I haven't had time to upgrade to it yet. But I plan to do it on the next week.

I will also investigate if it's possible to use the new Notify action (which is a server-side version of the NotifyWidget, and was introduced with 9.1).
Thanks Leonardo
Leonardo Fernandes wrote:
Hi Gavin, Version 9.1 is fairly recent so I haven't had time to upgrade to it yet. But I plan to do it on the next week.

I will also investigate if it's possible to use the new Notify action (which is a server-side version of the NotifyWidget, and was introduced with 9.1).
 Yep, I ran across the same issue when I upgraded.  'd offer to help update it but it looks like you kept the source.  Do you still plan to update it?  Let me know if I can help.  I found it to be very useful work-around to how weblocks work in OS.  Thanks!
 
Hi Marco. I'm sorry for the delay.
Yes, I am planning to update it. In fact, you can expect an updated version this week.

Best regards,
Leonardo Fernandes
The attached extension solves the incompatibility with Platform 9 Bali. Proceed with the following steps:

1. Publish the attached extension to your server.
2. Publish the events module.
3. Publish any applications that are using the event system component.

Please let me know if you find any issues.
Best regards,
Leonardo Fernandes
Thanks Leonardo,

I've installed and done some basic testing, all looks to be behaving as expected.

Cheers,
Gavin
Leonardo Fernandes wrote:
The attached extension solves the incompatibility with Platform 9 Bali. Proceed with the following steps:

1. Publish the attached extension to your server.
2. Publish the events module.
3. Publish any applications that are using the event system component.

Please let me know if you find any issues.
Best regards,
Leonardo Fernandes
 
 Awesome!  Thanks Leonardo, this fixed the issues we had as well.

Best,
Marco

Hi Leonardo,

It seems I am getting this same error when using the new P10  v10.0105.0

No rush yet - Just experimenting.

Regards, Lester