[BulkInsert] Support for 9.0.x

[BulkInsert] Support for 9.0.x

  
Forge Component
(5)
Published on 2015-11-24 by João Pedro Abreu
5 votes
Published on 2015-11-24 by João Pedro Abreu
Hi Guys, 

Is it possible to have this component running in the previous plataform version? There are no schedule yet to migrate to bali, but this component will be very usefull for us.

Tks
Fabio

Greetings,

I don't have any plans to make a 9.0 version of the component, seeing as I don't have an infrastructure to test it on. If you're very interested in using this, you could try making a 9.0 version of the extension by copying the its C# and Java code (it should work on 9.0).
Hi João, 

I´ve created a new version of this extension to work in a previous version of platform as you suggest. There are few changes in the code, because the java version, but it was not complicated.   


Thanks a lot
Fabio

Hi Fabio, 

Can you share your 9.0.x version?

Tks,
Artur

Fantato wrote:
Hi João, 

I´ve created a new version of this extension to work in a previous version of platform as you suggest. There are few changes in the code, because the java version, but it was not complicated.   


Thanks a lot
Fabio
 
 
 
Hi Artur,

I developed this for a customer and I don´t keep the copy of this version. I am trying to contact him to ask for it. If I could do it , I will post here.
But the processes was not too dificult to do again.

First of all. Create one extension in your environment and copy exactly the same actions and signatures into it.
After that , open in your environment (java or c#).

Copy the original source code into this new one you have been just create.

After that only fix the code if you need. For C# I guess there are no one fix to do. But for Java you will have 3 error. All of them is about generic type, just complete with the correct variable type and save it. Your extension will be ready to be published.

Anyway , I will try to get it with my customer. As soon as possible I post it here.

Best regards
Fabio



Artur Roussado wrote:
Hi Fabio, 


Can you share your 9.0.x version?

Tks,
Artur

Fantato wrote:
Hi João, 

I´ve created a new version of this extension to work in a previous version of platform as you suggest. There are few changes in the code, because the java version, but it was not complicated.   


Thanks a lot
Fabio
 
 
 
 
 
Still no version for 9.0.X?

?

David Chen wrote:

Still no version for 9.0.X?

I'm not planning on making a version for 9.0, since I don't have a platform I can test it on. From the lack of response from Fantato, I guess he couldn't get his version, or he forgot. Maybe you could contact him directly for an update on that.


Hi David, sorry for late answer.  Unfortunately I could not get access to the version with our customer. They decide to use another strategy, so someone remove that component for their environment.

I don´t have any environment with 9.0 to do and test this version again. But you could reproduce it in a simple steps:

1. Install Development Studio from 9.1 and open the xif from Bulk Insert. You don´t need an environment to connect, because you will use the integration only to open it and save source code into local machine. 

2. After that, create in your integration 9.0 the same actions and methods that the original xif. (Use the sames actions names and attributes). Save this one.

3. Open .Net folder in your Visual Studio and copy and paste the entire content to BulkInsert class from the original one.  This will be work without any errors

4.  Open Java folder in your Eclipse and do the same. In this case, 2 errors will be found, because the java 8 supports generic types and java 6 do not support. To fix it, just do the automatic fix that eclipse suggests.

5. Finaly save your xif and publish it into your environment.

Note: if you use only .net or java and you do not have the other env configured in your machine, just change the application type to yours and save. TYhe integration will remove the code unnecessary and you could compile it successfuly.

It is really an easy procedure.


Good luck. Let me know you have any issues and I try to help you.

Best Regards

Fantato





João Pedro Abreu wrote:

David Chen wrote:

Still no version for 9.0.X?

I'm not planning on making a version for 9.0, since I don't have a platform I can test it on. From the lack of response from Fantato, I guess he couldn't get his version, or he forgot. Maybe you could contact him directly for an update on that.