ServiceStudio is not compatible with Platform Server

ServiceStudio is not compatible with Platform Server

  
Good day.

Last week I was using ServiceStudio 9.0.1.40 (if memory serves me correct) this morning I got the following message after starting ServiceStudio: This version of ServiceStudio (9.0.1.40) is not compatible with the selected Platform Server (9.1.0.20).

As I closed the Incompatible Versions message. I recieved a message that there is a new version of ServiceStudio available. I proceeded to download and install version 9.0.1.50 of Service Studio but I still get the Incompatible message. I don't see a new version for Platform Server on the Downloads page.

I have not changed any settings on the Platform Server side, why do I get the Incompatible Versions message?

Kind regards,
Gerrie

Hi im having the same issue
Hello Gerrie,

You're connecting to a Platform Server 9.1.0.20 with a Development Environment version 9.0.1.x. That's why you get that error.

Is the Platform Server your Personal Environment? I ask this because OutSystems is upgrading the old 9.0.1.x Personal Environments to the latest version.

Regardless, you can get the compatible Development Environment version from https://www.outsystems.com/home/downloads/

Let me know how it goes.

Cheers
Hi all.

I'm facing this same issue.

After the upgrade of the Development Environment to version 9.1.0.20 I'm able to access my Personal Environment. But with this version of the Development Environment I'm not able to connect to another Development Environment running Platform Server version 9.0.1.20.

The Development Enviroment 9.1.x.x is not compatible with Platform Server version 9.0.1.20 ?
Thank you.
Best regards.


Miguel João wrote:
Hello Gerrie,

You're connecting to a Platform Server 9.1.0.20 with a Development Environment version 9.0.1.x. That's why you get that error.

Is the Platform Server your Personal Environment? I ask this because OutSystems is upgrading the old 9.0.1.x Personal Environments to the latest version.

Regardless, you can get the compatible Development Environment version from https://www.outsystems.com/home/downloads/

Let me know how it goes.

Cheers
 Hi, Miguel.

Thank you! After downloading and installing Development Environment 9.1.0.20 everything is back to normal.

Kind regards,
Gerrie
 
Hello Pedro,

The Development Environment 9.1.0.x is compatible with Platform Server 9.1.0.x, while the Developement environment 9.0.1.x is compatible with Platform Server 9.0.1.x.

Basically, in order to connect a Development Environment to a Platform Server you need to have the same major version. A major version is the first 3 numbers (e.g, 9.1.0). You can have multiple Development Environments installed on your computer, but the last one installed will be the default to open your application modules (.oml and .xif files).

This is quite straightforward, but it doesn't help when the top major versions are 9.0.1.20 and 9.1.0.20 :) It gets confusing, but with the release of new patches these numbers will change.

Hope this information helps.

Cheers

Miguel