HTTPS error -HTTPS connection required for this screen

HTTPS error -HTTPS connection required for this screen

  
When a webscreen security is set to HTTPS

I point my browser to https://server/espace/Webscreen1.aspx an error occurs

"HTTPS connection required for this screen"


When i point my browser to 
https://server/ the SSL is working! the browser displays a green padlock.

What is going on here? 

That is STRANGE. Never heard of that before!

J.Ja
Hi there,

did you verify the "HTTP Security" for your web sceen?

Regards.
João Rosado wrote:
Hi Robert,

Are you using https offloading in your load balancer?
Check this topic on how to configure it: https://success.outsystems.com/Support/Enterprise_Customers/Maintenance_and_Operations/OutSystems_Platform_in_Reverse_Proxy_scenarios/03_OutSystems_Platform_configurations_in_reverse_proxy_scenarios#C_-_End-to-end_SSL_and_SSL_Offloading


Regards,
João Rosado
 Joao

thanks for that article link.

We use cloudflare reverse proxy www.cloudflare.com

I managed to get everything working by changing cloudflare SSL settings to use "FULL SSL"
 
Hi Robert,

The green bar on the browser only tells us that the connection between the client and cloudfront is being done in https. It tells us nothing about the connection between cloudfront and the platform.

That error is very explicit. It means that the connection between them is done in http instead of https.
- If in your configuration you meant to have cloudfront contact the platform using https, its not working as you wanted.
- If you want it just to be http between them you will need to configure the settings in the platform as explained in the topic I linked, to make the platforn behave as all are https requests being proxied as http.

Regards,
João Rosado
Joao

That is correct.

"- If you want it just to be http between them you will need to configure the settings in the platform as explained in the topic I linked, to make the platforn behave as all are https requests being proxied as http."

I set all outsystems platform servers to use SSL (setup as end to end SSL via cloudflare)