.NET Framework versions and Microsoft Support Lifecycle Policy

.NET Framework versions and Microsoft Support Lifecycle Policy

Since earlier this month, Microsoft stopped technical support and security updates for Microsoft .NET Framework versions 4, 4.5, and 4.5.1.

If you are still running any of these versions on your OutSystems Platform server, we recommend you to upgrade to .NET Framework 4.5.2 as soon as possible.
.NET Framework 4.5.2 is currently the latest .NET Framework supported by OutSystems Platform. 

For more details, check the Microsoft .NET Framework Support Lifecycle Policy FAQ.

Hi João, 

your post suggests that .NET Framework 3.5 and 4.5.1 are not needed anymore for the installation of the OutSystems Platform server. However when I check the system requirements or download the OutSystems Platform 9.0 installation checklist it still refers to .NET 3.5. 

Can the installation checklist be updated or a new one created to use only .NET Framework 4.5.2 as you suggested?

Hi Sjoerd,

.NET Fx 4.5.2 is an in-place update to the .NET 4.x family (as described in the Microsoft article I referred above).

This means you cannot install .NET Fx 4.5.2 and 4.5.1 on the same system. 

On the other hand, you can have both .NET 4.x and .NET 3.5.x running on the same server. Whenever you have applications that require both versions, as it is the case of OutSystems, that's exactly what you need to do.

We will update the checklist as those requirements change in the future.