[Silk UI Web] Data from fields missing when navigation tabs control is used

[Silk UI Web] Data from fields missing when navigation tabs control is used

  
Forge Component
(47)
Published on 11 Nov (4 weeks ago) by OutSystems Labs
47 votes
Published on 11 Nov (4 weeks ago) by OutSystems Labs
Hi,

I am creating a form filling application and I divided the form across three tabs using navigation tabs control. After filling the data from first tab and navigating to the second, the data on first tab  remains but while selecting few buttons in other tabs makes data in fields from first tab to dissappear. Is this a normal behavior for a tab control to lose data when doing like this or if I'm missing/doing something wrong when using this control. 

I'm ajax refreshing only the container having the calendar corresponding to it.. Is this a problem as navigation tabs contain three different forms in each content and I'm just trying to ajax refresh only a particular field in a specific form.

Please refer to the images attached. Please Advise.

Hello Vimal,

Sorry for the late reply.

Looking at your screenshots and to your descriptions, we cannot see anything wrong, but we also cannot fully understand what you are doing with your ajax refreshs.
Can you please replicate the issue on a "clean" eSpace and share that eSpace with us, so that we can take a closer look to your code and better understand what may be causing the issue ? 

Best regards,
Samuel Jesus
Solution
Thank You. I wzs not able to replicate this issue in clean espace. I'm still confused what might cause the issue. BUt recently I have updated the SILKUI framework to new version and the issue is resolved now. Thanks all for the help. 
Solution