Unable to publish to Personal Environment - SOLVED - Status Updated

Unable to publish to Personal Environment - SOLVED - Status Updated

  
Hi there,

We achieved an important milestone last week with the upgrade of all Personal Environments to the latest OutSystems Platform release, 9.1.0.20. This morning we received a few reports from some users who were unable to publish their applications. To our shock, this was caused by an issue in this version. Fortunately, no Enterprise Customers were affected.


No applications or data have been lost and everything will return to normal as soon as our team deploys a new fix. We hope to have it done as soon as possible.


You’ve put your trust in OutSystems to keep your personal applications running smoothly, and we know how frustrated and disappointed you might feel if you’ve been trying - and failing - to publish applications. Our words can’t express how deeply sorry we are.


Please know that as soon as this issue is resolved, we’ll be looking at ways to ensure that this never happens again.


Again, please accept our deepest apologies. We’ll update you shortly to let you know when everything is restored.


In the meantime, if you have questions or are experiencing issues, please don’t hesitate to email the team directly at success@outsystems.com.


Regards,

Ricardo Araújo

Manager of Customer Success
Hi again,
 
following up my post, we re-established all Personals Environments and you’ve been able to publish your apps since yesterday at 17:00GMT. 
 
As previously mentioned, no applications or data have been lost and everything has returned to the regular service level. If you have questions or you are experiencing any issues, please don’t hesitate to email the team directly at success@outsystems.com.
 
We learned a lot from this challenge and feel very confident in our ability to prevent them from repeating. We'll get to work on improvements right away. In the meantime I hope you have a great weekend!
 
Ricardo Araújo
Manager of Customer Success
Too bad: Still can't publish my application. Hope the issue will be solved soon.
Hi René,

Should be fixed now. Please give it another try and let us know.

Thanks.
Can't publish to personal environment since yesterday. In Environment Health Problems I have "Deployment service is down in front-end SERVER." message. 
Hi Mykola, 

We're looking at it, as soon as it's ready we'll let you know.

Sorry the inconvenience, 
Ricardo
Hi Mykola, 

Sorry for taking so long, it should be solved by now. Can you check it?

Thanks
Ricardo
Hi Ricardo,
All is working ok now.
Thank you.
Hello,

I'm facing the same issue with constant server errors with a page like the following:

This has been happening in a more or less random fashion for around 2 days now... I don't have many dependencies in my app and I'm consuming data from one SOAP web service...


Hi Bruno,

As the error is only happening when opening the "Gestao de Reservas" the issue might me on the application side.
As part of the team in charge of helping our personal environment users I'll do the follow-up on your issue on the email that you have sent to us.

Cheers!
Thank you very much!

I will look forward to hear from you.

It's a bit strange as the app doesn't 'misbehave' at all apart from the webservice consumption, and appears to fail randomly... All the other screens have very simple logic...