[Chat] Error uploading Office files

[Chat] Error uploading Office files

  
Forge Component
(29)
Published on 2015-11-24 by Hélio Dolores
29 votes
Published on 2015-11-24 by Hélio Dolores
Hello,

When I try to send an Office file like Word and Excel, I got an error on upload. Can someone help me with that?

Thanks
Hi Luis,

Can you give me more information about this issue?
- Which error is presented to you? 
- How big is the file you're uploading? + 5Mb?

Thanks!

Hello,

The files are .docx or .xlsx and the error I got is in the picture attachment. The file size is about 15/20kb.
Do you know any limitation?
I really don't know why this is happening. Are you able to see the server.js log? 

You should see something like this: 

                    console.log("---------------<ERROR>-----------------");
                    console.log(res.Value);
                    console.log("---------------</ERROR>----------------");

Let me know if you can :)
Hello!

Yes, the error is:

---------------<ERROR>-----------------
Error: String or binary data would be truncated.
The statement has been terminated.
---------------</ERROR>----------------

Any ideia?

Thanks
Humm, it might be some sort of interruption. Are you behind a firewall or something?
Have you tried to upload a similar file to my example here: http://heliodolores.outsystemscloud.com/social/ ?



Yes I tried and got the same error.

I found the solution!

The problem is the lengh of the field Chat_File.Type on BD. Is only 50 and the Mime Type of docx have 72 characteres, is:  application/vnd.openxmlformats-officedocument.wordprocessingml.document

I change lenght to 100 and works!
Great catch :) I'll add it to my backlog too.

Thank you for reporting this Luis!