[Event System] Can't point Trigger at Menu Id

[Event System] Can't point Trigger at Menu Id

  
Forge Component
(17)
Published on 15 Feb by Leonardo Fernandes
17 votes
Published on 15 Feb by Leonardo Fernandes
Hi Leonardo.  I am trying to use the Trigger event from within a screen action.  I have the EventHandler located inside the Menu web-block.  I want to trigger the menu to update based on something my screen has done.  However I can't set the ParentWidgetId to the Id of the Menu web-block.  It isn't a suggested item and I can't find it in the expression editor.  I have played with customising the Menu web-block's name etc but that makes no difference.

I wish I could tell you which version of the Events System I am using but I can't work out where/how to confirm that.

I am running 9.1.0.20 in Development mode.

Also, I always have trouble accessing your support pages.  Sometimes I can get to a page via a Google search link, but any time I try to navigate from there to another page I am thrown back to https://www.outsystems.com/home/Suspended.aspx?Host=leonardofernandes.outsystemscloud.com.  From that point on I can't even get back to the original page.  I've tried different browsers with the same effect.  I am a Personal env user.
Hi. For the ParentWidgetId, you can use whichever container is a parent of the event handler.

I suppose that you don't have the menu on the context of the page, because the menu itself is contained in another block. But, in the end, it must be included by some web block that is directly used on the page. You can give this web block a name, and then use it as a parent.

Regarding my help pages, it seems that my personal environment is having problems. My guess is that they are upgrading it. Hopefully it will be back shortly.
Thanks - I get it now.  I have named the Common\Menu web block under the Menu placeholder right at the top of the page widget hierarchy and have now pointed at its ID.

However when the Trigger action is reached I get the following error message (which I think I recognise from another post in this forum?):



Regarding your personal web site, I'll just mention that I have seen the same behaviour multiple times in the past, not just today.
Hi again. This message indicates that you are using the wrong version of the Event System. From the message I get that you are using the server on version 9.0.1.25. You should try using the Event System version 9.4.9, which was the last one with support for 9.0.1.*. Download it here, and if you continue to get the same error, let me know.
OK thanks again for the quick replies.  Sorry for the dumb question but if you could make a few comments about how best to upgrade an existing Application using a new OAP file that would be much appreciated.  I know how to look in the ServiceCenter, Factory, Applications list, then "Publish and Application".  But I am concerned that I will end up with a duplicate of the Event System application, and this whole area is a bit murky.
You can use the Publish Application in Service Center, as you have mentioned. It won't duplicate the application, instead it will simply upgrade it to a newer version. Or, usually, you can double-click the .oap file, and it will open in Service Studio and start installing.

Note that you will have to republish your application after having the new version of the Event System, for it to use the newer version.

Best regards,
Leonardo Fernandes
Just confirming that that all worked as you described, so thanks again for that.

PS - your personal site all appears to be working correctly right now, JFYI.
Glad to hear that you were able to work it out.
Yes, my site was upgraded to the latest platform version, hence the downtime. But on the same day that you have reported, it was up again.