A function to reset the timeout inside of a process.

A function to reset the timeout inside of a process.

I have a process of TriggerBatchProcessing with a query of getting 20,000+ records, as I run the process, it keeps on Aborting the Thread. I have set the default timeout in the Configuration Tool from 30 secs. to 900 secs., as well as the Long Operations Timeout to 6000, not to mention that my query(GetAllDetails) has also a Timeout of 21600.

I tried to run it with a breakpoint, checking the result of the query. And the whole process was finished after the breakpoint. We are now looking for the possibility of resetting the timeout inside our process.

Hope you can help us, thanks.
Hi John,
I would suggest to do it in the other way around.
Set the timeout in the configuration tool to the default, and increase the timeout for that specific operation.

I believe that you are experiencing a similar problem as discussed here, as Joao Rosado suggested:

1) So the normal recommendation is to break big activities into smaller ones.
2) Change that funcionality and implement it on a timer.

Please find more information about timeouts here:



Hope it helps you!
Best regards.
Daniel Martins.
Thank you very much, we'll definitely try this out.

OK John,

Just let us know how it worked for you!

Best regards.