Email Functionality

Email Functionality

  

Can any one help me how to implement email funcionality.  eiether with RichMail or some other mail components.

I tried to implement got below error.

"No sunch host known"
have you configured your email settings like smtp and pasword in service center?

Yes i have configured, still i am getting error " 550.5.5.1 Protocol error <br>/RCPT TO:myMaild", can any one help me on this.
It seems you are sending something to "myMaild" instead of an e-mail address?
i am sending to my mail address only sv.nageshgupta@gmail.com
Is there any more error information? Some details?
Kilian Hekhuis wrote:
Is there any more error information? Some details? 
 
 
I am getting below error 550 5.5.1 Protocol error RCPT TO: sv.nageshgupta@gmail.com
Nagesh Gupta wrote:
Kilian Hekhuis wrote:
Is there any more error information? Some details? 
 
 
I am getting below error 550 5.5.1 Protocol error RCPT TO: sv.nageshgupta@gmail.com
Error sending email 2: 503 5.5.1 Error: authentication not enabled AUTH LOGIN at OutSystems.HubEdition.SMTP.SendMail.Send(String smtpserver, Int32 smtpserverport, AuthType authType, String username, String password, String mail, String from, String to, String cc, String bcc) at OutSystems.HubEdition.Scheduler.EmailJob.SendEmail() at OutSystems.HubEdition.Scheduler.EmailJob.Execute() at OutSystems.HubEdition.Scheduler.SchedulerProducerConsumer`1.<>c__DisplayClassa.
It seems you are trying to send an e-mail using an SMTP server that needs a username/password in order to send mail, and you are not providing them, or providing the wrong ones. In Service Center you can specify a Username and Password on the e-mail configuration screen (Administration -> Email).
Kilian Hekhuis wrote:
It seems you are trying to send an e-mail using an SMTP server that needs a username/password in order to send mail, and you are not providing them, or providing the wrong ones. In Service Center you can specify a Username and Password on the e-mail configuration screen (Administration -> Email).

I have already configured my email configuarations in service center, still i am getting error.
 
 

Well, according to a quick Google, a 503 "authentication not enabled" error means you specify a username/password, but the SMTP server doesn't want one. Try leaving them empty.
yeah Killian is right..
just make the username and password empty with only smtp address and port filled in.

Thanks for the reply, Mail is working now.