Cloud Personal Environment x local Oracle database

Cloud Personal Environment x local Oracle database

  
Hello evryone!

Do you know about some common restrictions or problems on trying to connect the local (localhost) Oracle database using Cloud Personal Environement? Using ServiceCenter in Database Connections I don't get connect to Oracle. Error message is always ORA-12541: TNS: No listener 
Already try several times but no success!
Any other local applications on my machine gets connection normally. The problem is just on Outsystems platform.
Please, can anybody help me?

Thanks.

DARCIO DOMINGUES 
Hi Darcio,

Because you have no way of accessing tnsnames in a personal environment you need to use a connection string with a format that doesn't require it. i suggest using with this format or try the different ones that you can find on connectionstrings.com.

You also have the use the public address of the machine where the DB is hosted and not localhost because the server won't find a DB on that address.

Cheers,
Guilherme
Hi Guilherme.

I understood that well so LOCALHOST is not better approach to server name.
I will perform some tests about this.

Thank you very much.

Regards.
DARCIO DOMINGUES
Dear Guilherme.
 
Unfortunately, after spending the whole sunday around this ... I can tell you that I could not to get any successful connection from any Oracle database.. I tried several different instances. Because you said my problem could be localhost installation or notation then after frustrated local test I created a Amazon RDS instance with public endpoint and oeven so I really got nothing good....
Amazon RDS is available in the web... so much that I got a good connection from my PL/SQL Developer on my notebook.. all works good... but on the other hands, from Outssystems Platform no success!. The message now is "Connection String test failed: Connection request timed out"
Below are data about my amazon Rds service for testing:

Endpoint (server): dd-aws-rds.ctc4eqwnxe9r.us-east-1.rds.amazonaws.com
Port: 1521
Service Name: orcl
User: OUTSYSTEMS
Password: outsystems

Please help on this otherwise I will stop to learning Outsystems.. cause for me just database use makes sense.

regards.
DARCIO DOMINGUES
Hi Darcio,

I've tried to connect using the credentials you provided and got the same error. Either in SQLServeloper


or just trying to reach the address provided (I even tried by IP just in case)



From my experience with amazon RDS you need a VPN or enable a specific IP address to be able to connect so you should check with Amazon if your DB presents the same restriction. 

To test you should try to connect from a diffent network. Once that's possible you should be able to connect from a personal environment as well.

Cheers,
Guilherme
Dear Darcio,

Please validate which IPs are you allowing to access your RDS in AWS VPC security groups. You can select the option "public accessible" in RDS settings, but you must configure your vpc security groups to allow inbound traffic too. E.g port 1521(ORACLE-RDS) from 0.0.0.0/0 (your rds is now accessible from anywhere, I don't advise to do this, just do it for testing purposes )

Best Regards,
Mário Pereira
Guilherme.
 
Thank you so much again by answering me.
Look this... What you tell me sounds a little bit strange because I got connection from PL/SQL Developer normally yesterday and today using the same credentials... see the print attached. Are the connection method and protocol different among SQL Developer and PL/SQL Developer?... also about TELNET is true we cannot connect at port 1521..... The hardest part is for the Oracle to work fine.. is very very necessary you have a infraestructure's team or even quite knowledge about "network" and so on..... Not seems possible to learn under Personal environment so it's much difficult to keep going. Instead of spending time to learn Outsystems development (quite interesting to me) I have first to learn so much about "network problems" to solve my Oracle connection (it's not interesting to me) because I'm a developer.
So, tell me... how can I get a local installation for learning?? Is there this option?? This way I could jump up this network problems whose expertise is missing to me.
Also I will try a VPN on RDS service even I don't trust on this.

Regards.
DARCIO DOMINGUES
Mário Pereira wrote:
Dear Darcio,

Please validate which IPs are you allowing to access your RDS in AWS VPC security groups. You can select the option "public accessible" in RDS settings, but you must configure your vpc security groups to allow inbound traffic too. E.g port 1521(ORACLE-RDS) from 0.0.0.0/0 (your rds is now accessible from anywhere, I don't advise to do this, just do it for testing purposes )

Best Regards,
Mário Pereira
 
Hi Mario.

I'm gonna make a test about you said!
Later I post my RDS configuration print.

regards.
DARCIO DOMINGUES

Dear Darcio,

Can you show me your Security Group configuration and RDS configuration?  
Thanks in advance

Best Regards,
Mário Pereira
Dears Mario and Guilherme.

I'm really happy!!!
Mario's tips are great and make working now!
I did set up Inbound VPC option like you said...
Now I get the Oracle connection.
See the print attached.

Uhhhh.. great help mrs.

Regards.
DARCIO DOMINGUES
Mario.

According to asked by you a Pint is attached containing my specific Security Group for RDS service.
Like I said before...i got a Oracle connection after your tips.
Thank you so much.

regards.
DARCIO DOMINGUES
Dear Darcio,

That is great! You are more than welcome, I'm glad I was able to help.

Once again, you should not use 0.0.0.0/0. If you want to connect your Personal to an external RDS, you should do a ping to your personal environment address and use the external IP of your personal (which you are able to retrieve after doing ping). 

However if the database in question that you are using is just for 
development and testing and if security is not a priority, you can use 0.0.0.0/0. But dont forget i dont advise you to do that :)
 
Best Regards,

Mário Pereira
Dear Mário.


I understood the risk well!!! 
I will make a change on RDS settings.

Thank you.

Regards
DARCIO DOMINGUES