262
Views
9
Comments
Solved
Nested SilkUI Accordion
I have nested a SilkUI accordion widget inside another within my app and noticed that I have no control over the inner widget. The inner widget is contained within a webblock. The outer accordion behaves as expected (can collapse and expand), however, the inner accordion is always expanded, and cannot collapse. Any help is appreciated. Thanks!
Staff
Rank: #204
Solution
Hello,

There is indeed a problem with the Accordion when its inside of each other. 
We are adding this issue to our backlog.

Justin, can you provide some details on the issue you found with the Expandable Sections? Is it the same behaviour reported by Ryan?

Cheers,
Samuel Jesus
mvp_badge
MVP
Rank: #105
It's probaly a bug. I guess there's some JQuery selector in Silk UI accordion script that is fetching undesirable results, since you put another accordion inside itself. Try to use the Section Expandable widget instead, maybe it works for you.

Best regards.
Rank: #4102
Thanks for the suggestion. I tried nesting the Section Expandable widget and it works (I can expand and collapse the inner widget)! However, I'm getting the following error message when the screen is rendered, "An exception occurred in the client script. Error: Cannot read property 'server' of undefined".
mvp_badge
MVP
Rank: #105
Well.. that looks like a Javascript error, but it's very weird. Have you added some custom Javascript to your module? The same error occurs in all browsers?
mvp_badge
MVP
Rank: #7

Nested Expandable Sections has some issues, I've found. I suspect the accordion has similar issues. I switched to the regular sections. Also, my experience has been that nested expandable sections and accordions is *usually* a red flag for UI/UX/design... it means that the screen is too complicated and has too much stuff on it.

J.Ja
Staff
Rank: #204
Solution
Hello,

There is indeed a problem with the Accordion when its inside of each other. 
We are adding this issue to our backlog.

Justin, can you provide some details on the issue you found with the Expandable Sections? Is it the same behaviour reported by Ryan?

Cheers,
Samuel Jesus
Rank: #4102
Thanks for all the suggestions and feedback! The issue I reported with the Section Expandable went away when I updated to the latest version of Silk UI. I believe I was experiencing the same issue reported here, https://www.outsystems.com/forums/discussion/15113/bugs-suggestions/#Post62830. Also, glad to hear the issue with the accordion is already on the backlog.
mvp_badge
MVP
Rank: #7
Stuff would break on Ajax Refresh for me, so I had to pull them out. Don't remember the exact details, it was 4 months ago.

J.Ja
Rank: #30647

It looks like this issue has not been solved yet... Am I forced to use expandable sections as a workaround?

Rank: #2732

Is this issue resolved? Kindly provide workaround for this if any.