Problem installing Community 8.0 version

Problem installing Community 8.0 version

  
Hi,

So I'm trying to install a 8.0 community edition on a Windows Server 2012 with a SQL Server 2012 (the 2005 version was not compatible). I did this by installing the SQL Server first and the platform after.
 
The problem right now is that OS services don't start and the error in the event viewer is:
"Error openning connection to the database: Login failed for user 'OSLog'"
Of course replicated for the correct user for each service, but they all fail because os BD Login.

On the configuration tool all the "test connection" work fine and I did the "create/update schema" and the "grant permissions".

In management studio I can log in with all the platform users configured in the Configuration Tool and do queries without problem.

All DB users are enabled and I even gave them all "sysadmin" just to be sure it wasn't permissions.

So anyone has an idea on what can be happening here?

Cheers,
Hermínio
Hi,

Just to bump this one.
No one really has any suggestions? 

I'll also add that the collation is right and I've tried putting the BD in compatibility mode to SQL Server 2005 but that didn't help.

Cheers,
Hermínio
Hi Hermínio,

Not really, the connection done via configuration tool is about the same that is done on the services...so if it works there it is strange that doesn't work after.

Are you using Sql authentication or Windows authentication? I assume that you have the mixed mode authentication enabled on your sql server if using sql authentication, right?

Also were the users created by the configuration tool or did you create them manually on the database?

Regards,
João Rosado
Hi João,

I had mixed mode and the users were created by the setup. Anyway I got it working, but that involved a reinstallation of the server.

My best guess is it had something to do with some feature not being active before. The checklist for the 8.0 community setup only goes up to windows server 2008 and the 2012 has different options in different places. ;)

Cheers,
Hermínio
Good that you got it working :)