Service Studio Screen Render issues

Service Studio Screen Render issues

  
Is there a way to clear the display cache in Service Studio?  I'm getting a screen render issue that's made the program unusable.  There's no error screen being presented, but it looks the same as when Java or a browser has a full cache (menus not updating until mouse-over; items in the wrong location, etc.)

I've already tried uninstalling/reinstalling Service studio, Java, etc.  Is anyone else running into this issue, or is it just me?
Hi Daniel,

I honestly don't know what you mean. Service Studio is a Windows program, written in C# (at least that's what I've understood). I've never seen such issues in Windows. What version of Windows are you using?

I'm pretty sure there's no "display cache" associated with Windows programs.
I'm using the cloud-based dev environment.  I'm on windows 7.  I've only ever seen this type of problem on a Java-based web app and I was able to resolve it in the past by clearing the cache.  It looks like a memory leak issue, but I wasn't sure if that was server-side or client-side.  I was grasping at straws on my end, and uninstalled/reinstalled everything, up to and including Java.
Hi Daniel,

Java has nothing to do with it. Unless you have a private cloud running Java, there's no Java anywhere (the personal edition runs on .NET exclusively). Service Studio always runs client-side, and is a native Windows program written in .NET, so there's no Java there either. Memory leaks are luckily mostly a thing of the past (on platform 6 for example, opening and closing a large eSpace would add 100s of MBs to the memory used by SS), so I don't think that's the case. The only thing I can think of is that your work station is really low on free memory when this happens. Have you checked via the Windows Task Manager what the memory status is when this happens?
Yes.  Like I said, I cleared the Java cache because I was grasping at straws.

The very first thing I did was check task manager.  Around 300MB used by SS.  I've got 8GB of memory on my machine, and was using about 30% of my total availability while it's running.  It's a screen refresh issue.  The only reason I even brought up Java is because I regularly use another webapp that often runs into almost the exact same problem and that's what it uses.

Exact same symptoms, and that is my usual solution to it that works every time.  I was hoping that someone else had seen this problem and had a workaround.
Hi Daniel,

Like Killian said it's not usual to have that behavior. When working with many modules big modules at the same time it's easy to get it 1GB+ memory and I've never seen it with UI glitches like those.

Do you have all windows updates installed?
Can you usually reproduce it consistently, or does it happens randomly after some time?

Regards,
João Rosado
I've uninstalled and reinstalled the environment several times.  It's consistently unusable for me.  I can't even get past the initial log-in before I see the same issue.  If I try to log into a blank application, I still get render failures in the environment.

Here's what I'm working with:

OS Name    Microsoft Windows 7 Enterprise
Version    6.1.7601 Service Pack 1 Build 7601
Other OS Description     Not Available
OS Manufacturer    Microsoft Corporation
System Name    XXXXXXXXXXX
System Manufacturer    Hewlett-Packard
System Model    HP ZBook 15u G2
System Type    x64-based PC
Processor    Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz, 2401 Mhz, 2 Core(s), 4 Logical Processor(s)
BIOS Version/Date    Hewlett-Packard M71 Ver. 01.09, 9/1/2015
SMBIOS Version    2.7
Windows Directory    C:\WINDOWS
System Directory    C:\WINDOWS\system32
Boot Device    \Device\HarddiskVolume1
Locale    United States
Hardware Abstraction Layer    Version = "6.1.7601.17514"
User Name    XXXXXXX
Time Zone    Eastern Daylight Time
Installed Physical Memory (RAM)    8.00 GB
Total Physical Memory    7.88 GB
Available Physical Memory    4.30 GB
Total Virtual Memory    15.8 GB
Available Virtual Memory    11.8 GB
Page File Space    7.88 GB
Page File    C:\pagefile.sys
Graphics card info:

Name    Intel(R) HD Graphics 5500
PNP Device ID    PCI\VEN_8086&DEV_1616&SUBSYS_2216103C&REV_09\3&E89B380&0&10
Adapter Type    Intel(R) HD Graphics Family, Intel Corporation compatible
Adapter Description    Intel(R) HD Graphics 5500
Adapter RAM    1.00 GB (1,073,741,824 bytes)
Installed Drivers    igdumdim64.dll,igd10iumd64.dll,igd10iumd64.dll,igdumdim32,igd10iumd32,igd10iumd32
Driver Version    10.18.14.4280
INF File    oem456.inf (iBDWM_w7 section)
Color Planes    Not Available
Color Table Entries    4294967296
Resolution    1920 x 1080 x 60 hertz
Bits/Pixel    32
Memory Address    0xC0000000-0xC0FFFFFF
Memory Address    0xB0000000-0xBFFFFFFF
I/O Port    0x00006000-0x0000603F
IRQ Channel    IRQ 4294967288
I/O Port    0x000003B0-0x000003BB
I/O Port    0x000003C0-0x000003DF
Memory Address    0xA0000-0xBFFFF
Driver    c:\windows\system32\drivers\atikmpag.sys (8.14.1.6463, 660.51 KB (676,360 bytes), 3/20/2016 7:42 PM)
    
Name    AMD FirePro M4170
PNP Device ID    PCI\VEN_1002&DEV_6604&SUBSYS_8006103C&REV_00\4&20C8CF9F&0&00E4
Adapter Type    AMD Radeon Graphics Processor (0x6604), Advanced Micro Devices, Inc. compatible
Adapter Description    AMD FirePro M4170
Adapter RAM    1.00 GB (1,073,741,824 bytes)
Installed Drivers    aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,aticfx32,aticfx32,atiumd64.dll,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll
Driver Version    15.201.1301.0
INF File    oem485.inf (ati2mtag_R502 section)
Color Planes    Not Available
Color Table Entries    Not Available
Resolution    Not Available
Bits/Pixel    Not Available
Memory Address    0xA0000000-0xAFFFFFFF
Memory Address    0xC10C0000-0xC10FFFFF
I/O Port    0x00003F00-0x00003FFF
IRQ Channel    IRQ 4294967286
Driver    c:\windows\system32\drivers\atikmpag.sys (8.14.1.6463, 660.51 KB (676,360 bytes), 3/20/2016 7:42 PM)
Interesting, first time I see a laptop with 2 graphic cards working at the same time.

According to the documentation of the laptop you can in the AMD’s Catalyst Control Center software force applications to run on a specic card. Can you see if you can force Service Studio to run on a specific one (try the Firepro first and then the Intel one if doesn't solve it)? Also don't forget to restart Service Studio after setting it.

Regards,
João Rosado