OutsystemsNow open Word document in Ipad

OutsystemsNow open Word document in Ipad

  
Hi everyone,
I have an Outsystems Now application that have a download link that download's a MSWord document.
Using android, I have no problem downloading and opening the file with MSWord application.
In IOS, using Safari, the document is downloaded and open some preview of the file and in the top of the preview appears a link questioning if I want to open the document with MSWord application.
Using Outsystems Now application, when I click the link, the document is also downloaded and open the preview but the option to open the document with MSWord application is not available.
I need to open the document using MSWord application when the user is using Outsystems Now application.
Any sugestion?
Solution
Hi Vitor,

To to that you the link to download the presentation should have a specific format, namely the correct sheme for opening the external application. In the case of the MSWord it's ms-word:.
This means that an example of this would look like the following:
  • ms-word:ofv|u|http://contoso/Q4/budget.docx
You can see the full documentation at MSDN.

Let me know if you need anything else.
Cheers,
RG


Solution
Hi Ruben,
Thanks for your repply.
That solved part of my problem.
Once the document is in database, I created a page for download de document.
It receives the identifier of the document and in preparation of the DownloadPage, the document is downloaded (The page is with role anonimous).
In my edit screen, in the download button, I put the url for the download page :
"ms-word:ofe|u|SERVERNAME/MABIT_Now/DocumentDownload.aspx?DocumentId=123".
Now, in Ipad, when I click the link, it opens MS Word but the document cannot open, gives me the message: "It's not possible to connect to URL. Use a valid URL."
If I get the url of the link and put directly in the browser, the document is downloaded and appear the option to open with MS Word.
Any sugestion?
Thanks in advance :)

Hi Vitor,

Try the following approach:
  1. Use http in the url

    -- not working? --
     
  2. Use https in the url

    -- not working? --
     
  3. Add the document as a resource of the module (and say that it is to deploy to IIS)
    This way the file will be "physically" in an IIS folder

    -- still not working? --
     
  4. Try the url of a public know docx and see if it works

    -- c'mon! :P --
     
  5. Read further Microsoft documentation...
     
The idea is to troubleshoot the problem and eliminate variables.
Let me know how it goes.

Cheers,
RG