Disabling popup link

  
Hi,
I have a link that opens a popup...  Sometimes that link must be disabled.  But when I do that the Popup_Editor RichWidgets returns an error for the 'missing' link (it's disabled).  I can't disable the RichWidget, I can't disable the container, I don't know how to do this...  Anyone does ?
Regards,
Bob.  
Use an If widget and put the text with the link and the Popup Editor widget in one sentence and the text without the link in the other sentence.

http://www.outsystems.com/help/servicestudio/9.1/index.htm#t=Web_User_Interface%2FPresent_Conditional_Contents.htm
Hi Bob,

First, general questions like these are better asked in the Tech forum. This forum is meant for guides on how to do stuff, not for questions on how to do stuff. The Tech forum also gets much more attention from fellow OutSystems users, so you're more likely to get your questions answered there.

That said, I can't reproduce your error. If I change the Link's Visible property to False, no RichWidgets error appears. Can you share a minimal eSpace that shows your problem?
If I reproduce it with 'Visible = False' it works...  I get an error-message with 'Enabled = False'.
'Visible = False' is fine for me.
I can go on...  But I think it should be possible to disable a link...
And Carlos' solution is super...  That always works.
Yes, I didn't see Carlos reply (I was still editing mine), but wev'e user an If-widget before. It was just that I couldn't reproduce the error myself (and I didn't want to give you a faulty answer).