[Freeze Panes] Freeze Pane blocks filters in IE

[Freeze Panes] Freeze Pane blocks filters in IE

  
Forge Component
(3)
Published on 2014-10-22 by André Vieira
3 votes
Published on 2014-10-22 by André Vieira
Hello,

We are using Freeze Panes in our application and it is working fine for the most part and in Firefox we have no problems at all with it. In IE 9 or 11 we, however, face some problems.
We use it on pages where we can apply filters. When we try to apply filters or press the reset button, the page and table are not refreshed. In the picture attached you see the problem: the headers of the columns are not above the correct columns anymore...

Any suggestions as to how to solve this?

Regards,
Daan Brandenburg
Hi Daan,

I don't have any idea why it happens :( Can you try to isolate this problem in a new module that you can share with me so that I can take a look at it? Thanks.

Cheers
Hello Andre,

In the attachment you find the oml with the problem isolated. I have tried it in different browsers (firefox, chrome, edge and IE), but only in IE there are problems.
Hopefully you will be able to find something to come up with a suggestion to fix it...

Regards,
Daan Brandenburg
You can also test it out for yourself through this link: https://dbrandenburg.outsystemscloud.com/ProblemFreezePanes/Aansluitings.aspx?%28Not.Licensed.For.Production%29=
Hi Daan,

I'm sorry I didn't have the time to have a look at the issue.
It seems to me that this is a problem of the jquery plugin I used to create this Forge component.
Unfortunately, this takes some time to debug and probably the best way to move no would be to find another plugin since this one doesn't seem to have any updates for a while.

I'll keep this in my personal backlog, and I'm sorry if this doesn't fit your timings. 

Cheers
André Vieira wrote:
Hi Daan,

I'm sorry I didn't have the time to have a look at the issue.
It seems to me that this is a problem of the jquery plugin I used to create this Forge component.
Unfortunately, this takes some time to debug and probably the best way to move no would be to find another plugin since this one doesn't seem to have any updates for a while.

I'll keep this in my personal backlog, and I'm sorry if this doesn't fit your timings. 

Cheers
 Hello André,

Thanks for your answer. For now, we just left it out. If you do find a solution, we would be very interested in it...

Regards,
Daan
 
Hi Daan,

I already reported this problem. If I scroll down in IE after using Freeze Pane component, columns width (for headers only) gets decreased.

Check this post : http://www.outsystems.com/forums/discussion/16126/forge-component-not-working-in-internet-explorer/

Alternately, I used CSS over there and to some extent it solved my problem. Try using that.

Hope this helps.

Thanks and Regards,
Suraj Borade
Hello Suraj,

Thanks for your reply. I did see your post and have tried it as well. However, even though it does solve it to some extent, it is not what we are looking for.

Regards,
Daan
Hi Daan,

Yes I know it solves problem to some extent. Unfortunately we were not able to use Freeze Pane component in IE for list pages. I am thinking to raise support ticket.

I didn't get involved in that because our business users said that they are ok if it doesn't work in IE. It's working fine in Google Chrome and Mozilla Firefox.

Will update you when I get answer from support team.

Thanks,
Suraj Borade