[Html2PdfConverter] HTML2PDF: Images not loading?

[Html2PdfConverter] HTML2PDF: Images not loading?

  
Forge Component
(40)
Published on 24 Mar by Guilherme Pereira
40 votes
Published on 24 Mar by Guilherme Pereira
On 9.1.0.20, in the OutSystems cloud... pages with images are not loading, we get the dreaded error (below). I use the flag suggested and the PDF generates, but without the images, so I know that the problem is the images. Our version of HTML2PDF was uploaded on January, 2016, so it is NOT the most recent version.

When I use the "Network" tab of my browser and load the page manually, I get an HTTP 200 for all resources on the page, and I added a favico.ico to make sure that it shows too, but the error message indicates that something is not loading right or giving a non-200 status code. I tried it in a browser I never use, in private mode, to make sure that it wasn't a cookie/authentication/login issue.

How can I troubleshoot this? Is there something I need to do to sort this out? Should I update the component to a new version? Upload new binaries?

Thanks!

J.Ja

    Could not find file 'C:\Windows\TEMP\TEMPDGBGFGIUJO00000000000000000000000000000000.pdf'.
Error: Failed loading page http://RemovedURL (sometimes it will work just to ignore this error with --load-error-handling ignore)
Exit with code 1, due to unknown error.
Solution
Hi Justin,

Does it fail always on the same page or the intermitence in the errors is on different pages?

Are you by any chance using SILK UI? If so there's a known incompatibility due to a script that SILK UI inserts that causes the resources to not be loaded on wkhtml and the "solution" for it is to create an empty theme (not SILK Based) and use that as the theme for the pages that you need to print.

Cheers,
Guilherme
Solution
Yes, always fails on the same page, and yes, using SilkUI. I already was using a separate Layout for my print page, I just removed the SilkUI block on it and it worked. Thanks!

J.Ja