Configuration tool : Installation error when "apply and exit" is clicked

Configuration tool : Installation error when "apply and exit" is clicked

  
Windows 2008 R2 Enterprise, SP1
Outsystems Platform 9.1.401.0
SQL Server Express 2012

Note: previously this server had 9.0.1.25 running, it was uninstalled prior to installing 9.1.401.0



Hi Robert,

From the error it looks like it's failing to get a setting.
Did you keep the same database after uninstall/reinstall?
If yes, did you keep the private.key file from the previous installation?


Regards,
João Rosado
Joao

I uninstalled the old version, deleted the databases. Installed the latest version, it failed with error as shown above.
Next I uninstalled outsystems platform, deleted the outsystems directory, installed outsystems platform once again, same error as above.
 
Solution
Can you also try to remove the outsystems settings from the machine.config file?

Regards,
João Rosado
Solution
Thanks Joao

Removing all the old outsystems configurations settings from the machine.config file has resolved the issue!


Joao, I have the same problem here, but i just wanted to update the outsystems versions, because of that didn't install the previous version (9.0.X).

The outsystems setting that you said are these "<add key="OutSystems.PluginDirectory (DEFAULT)" value="C:\Program Files\OutSystems\Platform Server\plugins" />"? Located at C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config?

I removed all setting, but not the "Compiler.DatabaseUnicodeSupport (DEFAULT)", and I still can't finish the Configuration Tool installer. I have the exact same error that Robert posted.

Thanks.