[Html2PdfConverter] HtmlToPdfConverter cannot upload Required Binaries

Forge Component
Published on 5 Feb by Miguel 'Kelter' Antunes
69 votes
Published on 5 Feb by Miguel 'Kelter' Antunes

On the Administration page for HtmlToPdfConverter I cannot upload the required binaries (wkhtmltopdf.exe and wkhtmltopdf.exe).

Is this because I'm still using a trail account?  
Hi Mark,

Even in a trial environment you should be able to publish it.
What error are you getting?

Oh, thank you for following up on my questions.

I'm not getting any errors.  After clicking up uploadd, the page just hangs.

Hi Mark,

Have you tried to use chrome? It has a pretty nice indicator that should show you the upload upgrade.

What I saw in the past (that may seem a hang) is a timeoutduring the upload process and in that case the chorme indicator should show you a back to 0%. if that's the case I suggest using a faster connection (wired connection) and if necessary try to increase the maxrequest size using factory configuration as described in the FAQ.

Can you give it a go and tell us if it worked?

Wow, that's a slow upload.

Yeah, it was uploading - slowly.......... But then it would time out and reset to zero and start again.

I'll have to find a wired connection. 

Thanks for helping me solve my problem.


As an alternative approach to this problem - I would suggest looking at https://www.api2pdf.com/ - it is essentially the same solution but easier to implement. It is still using the wkhtmltopdf combined with aws lambda. It is incredibly cheap and scales. 

All you do then is call the API through Outsystems and you are done. 

The reason I chose this instead is that testing on the personal env, I was not able to change the factory settings - as this only supported on the commercial version.