Calendar not working since System Date Format change

Calendar not working since System Date Format change

I have recently changed the default format of the system date in Service Centre from YYYY-MM-DD to DD-MM-YYYY and since then the SilkUI Calendar control is no longer displaying the correct date in the drop down. The text box linked to it is still populating with the correct date in the new format. But when you drop down the calendar, it displays a calendar of the December 1899 with all navigation disabled, so I cannot successfully select any date.

I found a previous post that told me to change the Null Value of the Text box to NullDate() but the does not seem to have made any difference. I have tried setting the Initial Date and Min Date fields but again, nothing.

Any help you can give me would be brilliant. This issue is affecting every instance of the calendar drop down in every application we have so is super urgent!
Hi Jacqui,

You can use ajax calender instead of default calender widget.

Hi Jacqui,

The SilkUI calendar has its own date format property:

You'll have to explicitly set it if you have a date that's different from the system configure date. It's a bit of a pain though, and can easily be forgotten. In any case, use a site property or an action to return the date format, not set it with a string literal as above.
Perhaps I was not clear enough in my initial post. I have changed the default system date format (Set in Service Center). I have NOT set any explicit format on any of the calendar controls as I want it to use the default system date format. This change to the system date has broken every date field with a calendar attached - see the attached screen shot in initial post - whereby all navigation is disabled.
Hi Jacqui,

You were clear enough. The thing is that, as far as I'm aware, the Silk UI calendar does not use the default system date format and, as I explained above, you need to explicitly set the format on every calendar control in that case. I consider this an issue with the Platform (or at least Silk UI), but that's what it is.
I have done what you have suggested and explicitly set the date format of the control the "%d/%m/%Y". This has made no difference to the calendar. All functionality is still disabled. I think I am at the stage where I need to log a support case.

Hello Jacqui,

From your description it seems an older issue that was already solved.

Can you please check which version of Silk UI Framework you are using? 

To do so, please access the following link (replacing your server):


If you are on an older version, please check the Silk UI Framework Change Logs, and if possible, upgrade to the latest version.


Samuel Jesus