Google Maps Error

Google Maps Error



I've installed Google Maps from forge and added the API key. When I add a map to a page in a new module (HTTP request run java dependency is checked and page is public) I get the attached. Seems to be an easy fix but looking for help on where to start. I get the same error when launching the forge provided google map demo and selecting "multiple markers" menu item. 

Thanks, Mike

Hello Mike,

There seems to be some kind of issue with the Google Maps API, but to discover more details you need to check the errors in the console. To do this in Chrome or Firefox you press F12 and then select the tab Console. Here's more details on how to do this:

Once you discover the error message from Google Maps, you can check if you can find it in this page:

Let us know if you figure something out.

Thanks Paulo,

I did check out the error (attached) and maybe I have not set up proper referrers within the Google API console. I saw a previous note on this, but cant find any options or instructions on how to do this. I realize this is an unsupported component, so I appreciate any further help. Mike

The API key u are using is not bound to any project anymore. (or is not available anymore)
What you could do is create a new Project (via google api management) and generate a new API key.

Use that new API key instead.

Yes, I did this and entered the new key in OS Service Center w\the Google Maps demo application. It was not obvious or clear how to set-up the key in Google to "refer" it to any OutSystems URL, if that is also required. The steps seem simple - create project, create key, enter key into OutSystems. Am I missing something here?


well all, I just tried the application now and it works...maybe there's some processing time I'm not accounting for in the issuance of the keys? Thanks for your help, all is good. Mike

Good to know, Mike! Google API probably needs some time until the keys are fully active.