[Silk UI Web] SilkUI is not defined

Forge Component
(86)
Published on 25 Mar by OutSystems R&D
86 votes
Published on 25 Mar by OutSystems R&D

For the very first time, SilkUI isn't loading properly. I don't know what I'm doing different (as far as I know, nothing - and I have in this server other projects using it just fine).

Help?

Better image

Problem solved! Instead of creating an empty layout, just clone one that it's used on the themes and adapt. I was missing key "includes"!


Solution

Hello Otacon,

You are absolutely right. The problem was that you were using a custom layout without some of Silk UI requirements.

You can create your own layout, but you need to have the WidgetsForLayout pattern on the layout, and also you need to have a container enclosing everything with a specific set of classes:



Cheers,

Samuel Jesus


Solution

I am using London and trying to make this work so I can use Modal.  I have cloned the London Layout and it looks like the above.  I have tried putting the Layout\WidgetsForLayouts in multiple places on the page - but it doesnt appear to work.  How do I know what to enter in the:   GetCssGlobalContext() + "THEME"   Do I need to enter something other than London to be able to use Modal???



Hi Lisa,

What is your use case? If it's just about using Modal, you don't need to clone de London Layout (check the documentation for more details).

Also, this an old thread referring to SilkUI (probably in version 10) and you probably are using OutSystemsUI (version 11), which is SilkUI on steroids :). I also would like to recommend, in order to get faster answers, try to ask your question on a new thread, explaining what are you trying to achieve, that way you probably will get many ideas from the community on how to achieve your goal. 


Vera