Database error when publishing a column creation on an entity

Database error when publishing a column creation on an entity


I created a new column on an entity but when I try to publish Service Studio shows me a non sense error that refers to another entity.

The message says: 'Could not change the 'Credit.Createdby' attribute from 'Integer' to 'Integer''.

Weird thing 1: Couldn't convert 'Integer' to 'Integer'?!

Weird thing 2: I'm not changing anything on this table!!

Weird thing 3: This 'Credit' table is empty on the environment.

I have tried Studio, and

Server is on

Here is the error message:

Publishing Error
Unable to upgrade database schema. Could not change the 'Credit.Createdby' attribute from 'Integer' to 'Integer', since existing records could not be converted to 'Integer'.

Either rename 'Createdby' (data will remain in the database, but not accessible from your application) or create a process to handle the records with values that cannot be converted.

Press F1 for more information.

Hi Joao,

Did you try to revert your changes till the moment you can publish? Then you try to reimplement the changes you had made.

When I have those strange errors this workaround usually works.


Yes, I've tried, Thomas. But id didn't work.

By now the problem has disapeared. What I think is that error was related to a heavy load that was occurring during my publishing.

Some weird things:

1. Still the message makes no sense.. Couldn't convert Integer to Integer?

2. In a column that I didn't make any change

3. The load was not affecting neighter the table I changed nor the table that appeared on the weird error message

I wanna believe this is an error from the version that is already fixed on newer versions.