App from Forge does not appear in OutSystems Now (solved!)

App from Forge does not appear in OutSystems Now (solved!)


Update: I found the solution.

What happens is that the app downloaded from the Forge ended up in a bucket called Independent something. What I had to do was create a new application, move the downloaded module to this new application and set it as Home page. Then it appears in OutSystems Now.

Best regards,

Peter Nijhuis.


I downloaded an App from the Forge and published it without problems in my Environment.

However, when I try to open it from my smartphone in OutSystems Now it is not there.

In the webbrowser (OutSystemsNowService/Applications) the App from the Forge doesn't appear neither.

How can I access this app thru OutSystems Now?

Best Regards,

Peter Nijhuis.


Can you tell us what forge application was?

Maybe the owner can perform a change a replace the existing oml file for a complete application. That's probably the reason that made the module to be put in the Independent Module application.

In that case nobody else would have the same problem.


Carlos Sousa

Update: SOLVED!

My assumption was correct. I had to change the icon in the Outsystems Environment to a png-file of 128x128 pixels. After this I was able to upload the application to the Forge. An automatic image conversion function would be nice!

Hello Carlos,

Actually it is my own application (CasaAuthorization).

Today I tried to upload this application as an application (oap-file), version 2.0.0.

However, I get the following error:

Maybe this has something to do with the Icon? The Outsystems Environment doesn't allow to use the png-file I use in the Forge and the Forge doesn't allow the ico-file I use in the Environment. Catch-22?

Best regards,

Peter Nijhuis


I'm glad you're able to overcome the issue.

Regarding the image format: never had problems with a 128x128 or 96x96 image file :)