[Filter RecordList] New version working in 9.1.401.0 (.NET)

[Filter RecordList] New version working in 9.1.401.0 (.NET)

  
Forge Component
(1)
Published on 10 Aug by António Chinita
1 vote
Published on 10 Aug by António Chinita

Hi Guys,

I was trying to use this extension on my environment and I saw that was not working. The platform´s way to work with record lists by code change a little since the original version and only the upgrade was not enough.

I compare XML Records that is another extension that works good with record lists and fix the Filter Records using some elements from there. 

Now it is wotking good for .net in the version 9.1.401  

Here is the code to everyone to use. It is protected by ipp , so this version will not working in personal envs because that. If Antonio could upload this code into forge will better.


Best regards

Fábio


Solution

Fantato wrote:

Hi Guys,

I was trying to use this extension on my environment and I saw that was not working. The platform´s way to work with record lists by code change a little since the original version and only the upgrade was not enough.

I compare XML Records that is another extension that works good with record lists and fix the Filter Records using some elements from there. 

Now it is wotking good for .net in the version 9.1.401  

Here is the code to everyone to use. It is protected by ipp , so this version will not working in personal envs because that. If Antonio could upload this code into forge will better.


Best regards

Fábio


Uploaded your version, with due credits. (Version history)

Thanks! :)


Solution

Hi Folks

I was testing this component and I think I run into an issue.

Searching for an empty string on 3 attributes, triplicates the number of entries in the list

Can you confirm this?


Cheers

Rui Barbosa wrote:

Hi Folks

I was testing this component and I think I run into an issue.

Searching for an empty string on 3 attributes, triplicates the number of entries in the list

Can you confirm this?


Cheers

Hi Rui,

You are right. This case is replicating the elements. We found this bug too last week . We already fix it. I will ask Juliano to upload our fix here.

Best regards

Fabio



Appreciated!

Hi Rui,

Attached is the extent with the fix.

Best regards

Juliano

Seems to be working fine!


Thanks