[DBCleaner] Delete but does not delete

[DBCleaner] Delete but does not delete

  
Forge Component
(20)
Published on 17 Mar by Acácio Porta Nova
20 votes
Published on 17 Mar by Acácio Porta Nova

Hi

I've been using this component for a while and it generally does what it says on the box. Kudus to the author. (Parabems, as you say).

The problem I have there are a number of old unused table attributes that I have tried to drop and while the component says it has deleted them, the fact is, these simply will not delete at all. See the attached image file.

I suspect this happens because there is some sort of "lost" foreign key involved. The way OutSystems does its magic, things are not what they appear to be, and one's tables and attributes are not physically named in the database in the way that theyare named in the application, e.g., the table {MyApp"} might have a completely different name in the database. I imagine that when objects are deletd, they not really deleted at all, they're simply mapped out. The problem comes in when one object references another and because one or the other is invisible, they cannot be manipulated as such, because one doesn't really have access to the underlying database schema.

Very annoying all the same.

Any suggestions on how I can go about fixing this?



Cheers, and thanks for whatever attention you can give this.

Leo



Hi, sorry for the time it took me to get to this.

Can you share the contents of your ossys_entity and ossys_entity_attr tables ?

Tanks, Ricardo.

I would if I knew how?  :-)  In other words, how do I do this?

Ricardo Silva wrote:

Hi, sorry for the time it took me to get to this.

Can you share the contents of your ossys_entity and ossys_entity_attr tables ?