Deployment takes too long (up to 10 min)

  

Hi.

Few days ago we started to experience very critical issue with publishing. It takes up to 10 min to publish any eSapce. It stops at Deployment step ("Updating Oracle database model and deploying the web application to IIS.").

We tried to reboot the server, clean asp.net temporary files, and many other things, but noting helps.

What might be a reason for such slow publishing?

It is very urgent. Our development simply stopped.

Thank you in advance.

Hi Dmitry,

Don't know if you use Outsystems cloud or not, but anyway even if you have it on premises, you are able to get support from Outsystems. Get in touch with them.

Hi Dmitry,

If you have foreign eSpaces, please check whether there are cyclic dependencies between your eSpaces.

Please check whether you have Outdated references.

On every screen, please check no of local variables and confirm that whether those variables are in use or not. If not in use, please delete.

If these things are there, it takes time to publish and sometimes operation gets timed out.

Thanks,

Suraj Borade

Hi Dmitry,

Are you still facing this issue?

Publishing taking very long periods can have many different causes.

 Suraj has already pointed some common causes but if this issue is critical to your business we would strongly advice to open a case in Support Portal.

Ana Martins wrote:

Hi Dmitry,

Are you still facing this issue?

Publishing taking very long periods can have many different causes.

 Suraj has already pointed some common causes but if this issue is critical to your business we would strongly advice to open a case in Support Portal.

Yes, we still facing this issue. I will follow this advice and ask the support. Thanks.