Oracle connector for OutSystems P9.1

Oracle connector for OutSystems P9.1

  

hi there,

I have a problem when calling Oracle stored procedure with an input parameter .. error wrong number or types of parameter.

I use an Oracle Connector P.9.

My question is which version of Oracle Connector that suits for P9.1 and wher can i find a step by step tutorial that works?


tq.

Solution

Hi Indra,


If you're using OutSystems 9.1, then you're using the right component. This one differs from the older Oracle Connector in the driver the platform uses from 9.0 onwards.

The best documentation I can refer you to is the sample eSpace bundled with this connector.

Inside the eSpace you have several sample scripts under Data->Resources->scripts.zip. Paired with these, you have the corresponding structures which are defined for input / output parameter mapping. Please check these, and how they are used within each of the sample pages.


If you can share a bit more of what you're trying to achieve, I may be able to point you to the right direction.


Kind Regards,

João Grazina

Solution

Grazina wrote:

Hi Indra,


If you're using OutSystems 9.1, then you're using the right component. This one differs from the older Oracle Connector in the driver the platform uses from 9.0 onwards.

The best documentation I can refer you to is the sample eSpace bundled with this connector.

Inside the eSpace you have several sample scripts under Data->Resources->scripts.zip. Paired with these, you have the corresponding structures which are defined for input / output parameter mapping. Please check these, and how they are used within each of the sample pages.


If you can share a bit more of what you're trying to achieve, I may be able to point you to the right direction.


Kind Regards,

João Grazina


thank you sir.

my platform Version 9.1.501.0

I do not find any  Data->Resources->scripts.zip. it is in my espace/my application. Where can i find espace bundled with this connector? tq

for my case, i put in the following forum http://www.outsystems.com/forums/discussion/19990/no-parameter-passed/

tq

Grazina wrote:

Hi Indra,


If you're using OutSystems 9.1, then you're using the right component. This one differs from the older Oracle Connector in the driver the platform uses from 9.0 onwards.

The best documentation I can refer you to is the sample eSpace bundled with this connector.

Inside the eSpace you have several sample scripts under Data->Resources->scripts.zip. Paired with these, you have the corresponding structures which are defined for input / output parameter mapping. Please check these, and how they are used within each of the sample pages.


If you can share a bit more of what you're trying to achieve, I may be able to point you to the right direction.


Kind Regards,

João Grazina

It works, tq..struct is different with record