[OutSystems Now] HTTP/HTTPS

[OutSystems Now] HTTP/HTTPS

Forge Component
Published on 19 Oct (7 days ago) by OutSystems
33 votes
Published on 19 Oct (7 days ago) by OutSystems


Has anything in the coding changed in regards to connectivity?  We are running firewalls that are forcing HTTPS, and after the new version OutSystems Now is unable to connect.

It worked fine with HTTPS before.

I also checked settings in OutSystems Now eSpaces, no mention of HTTP/HTTPS there apart from the REST service which has SSL/TLS enabled (cannot disable it)...  This is an issue as we are offloading SSL to the firewalls and do not have SSL/TLS on the servers itself...

All of our apps worked without issue before the update, so what has been changed?

Any ideas?  Thanks!

Why exactly under the Integrations for eSpace OutSystemsNowService / Exposed REST APIs is the OutSystems integration set in such a way that it can not be changed?

Hello Riaan.

What error are you obtaining? Have you installed the new version of the component?



Errors regarding not being able to connect - and yes - user reports without details...  It was the new version of the component that started screwing things for us...

OutSystems Labs changed the HTTP/HTTPS settings in OutSystemsNowService module, even though OS Support said that nothing was changed, from HTTP to HTTPS...

We changed the module back to HTTP instead of the new default HTTPS and now it works again.

The reason for this not working for us is because we are doing SSL offloading onto our firewalls as well as Load-Balancing of our servers which force SSL on the firewall, but not inside the network.  This meant that because the service was requesting a local SSL which even though configured on the servers is not the way we are using it, the services didn't work for us.