[Common Plugin] Version 2.2.1 is giving me an incompatible error in OutSystems Now

[Common Plugin] Version 2.2.1 is giving me an incompatible error in OutSystems Now

  
Forge Component
(4)
Published on 2016-11-22 by OutSystems R&D
4 votes
Published on 2016-11-22 by OutSystems R&D

The latest version 2.2.1 as of 10/12/16 is given me this error in OutSystems Now: "Product 'CommonPlugins' module definition is incompatible, please update it."

Any suggestions on how to resolve this?

Solution

Hi Erik,


Make sure all your refences to CommonPlugins are up to date in the modules that reference it. Refresh them in the Add/Remove Dependencies window.

It should have compilation warnings when you publish them telling you that there is a broken reference.


Regards,
João Rosado

Solution

Hi, same problem, refreshing does not sove, any one fix it? unable to test beacons workshop


Regards

John

I had the same problem as Eric. Maybe I was not looking very well into the messages, but at the end it turned out to be the InAppBrowserPlugin that had to be upgraded.

I think this is one of the weaknesses of the Forge/Plugin system. There should be a sort of general check for all referenced plugins if there is a newer version. Or maybe somebody has a better idea.

Besides that, the initial screen of the Beacon Workshop is now showing, but when I press one of the options in the bottom bar, it always results in: 

"There was an error processing your request. RELOAD".

Regards,

Peter.