P10 Scroll not working on older versions of android?

P10 Scroll not working on older versions of android?

  

Hi guys,


I'm having problems using the scroll on my APP using Android 4.4.2, I've tested it in an Huawei phone and in NOX APP Player (emulator) both with 4.4.2.

I created an APP using Platform 10, generated the APK and after installing it I can't use the scroll (same thing happens using Outsystems Now).

 I've tested it using andoid 6.0 and using an Iphone and the scroll works.

In attachment is the Espace that I used to test the scroll on the phones.

Can you please tell me what i'm doing wrong, or Platform 10 does not support older android versions?


Thank you very much

-Luis Almeida

Hi Luis,

The problem is in the Menu block and has already been addressed in 10.0.105.0 (GA). You're using an old version of the common blocks (old template). I recommend that you create a new App, then copy and replace all common web-blocks in your app.

Hi João,

I just did what you said on my application, in fact, the OML in attachment on my original post was made using 10.0.105.0 and I still get the same behavior using Android 4.4.2

Probably you created the app in a previous version (and then upgraded), because the template has old assets that were present on versions before 105. Was that the case?

I'll recreate the app from scratch and see if I can get it to Work, but I don't think that happened.


EDIT: Just created another one from scratch and the Scroll still not works on Android 4.4.2, on Android 6 works as expected.

On Outsystems now it doesn't work also (using the Android 4.4.2)

Solution

Probably you didn't install the latest version of SILK in your environment. Did you?

Solution

Yeeah that was it, thank you very much!!!