How to install specific version of the plugin in OutSystems 10 ?

How to install specific version of the plugin in OutSystems 10 ?

  

Hi,

I have some troubles installing latest version of plugin to OS10 and I was wondering what is the proper way to install specific version of the plugin?

I've tried this:

{

    "plugin":

    {

        "url":"https://github.com/becvert/cordova-plugin-zeroconf#1.1.2"

    }


}


But app crashes on load now so I can't verify if plugin was installed at all.

Thans for any tip and advise of how to use plugin versions and debug Native application to find out where problems are.

Thank you




Solution

Hello Nick.

That's the correct way to install a specific version (Reference: Plugin-spec)

To help troubleshooting OutSystems apps, there's an article in the knowledge base with more information (still not complete). To debug plugins (the native part) you'll have to either use XCode, Android Studio or other IDE of your preference depending on the platform.

Thanks

Solution