[zTree] Outsystems 10 support

[zTree] Outsystems 10 support

  
Forge Component
(8)
Published on 13 Feb (13 days ago) by Eduardo Luís
8 votes
Published on 13 Feb (13 days ago) by Eduardo Luís

Hello,


Any plans for zTree to support Outsystems 10?

Hello,


yea sure, OS 10 is definitly in the plans for zTree. But not wright now, i'm a litle short in terms off time...

Anyaway, the migration process shouldn't bee to hard so when i manage to squeeze this in my limited amount of time there will be news.


Best regards

Hi Luis, wondering if you have any update on your timeline for OS 10 support?

Great tool by the way

Regards Ian

Hi Ian, mi available time didn't improve much since mi last post so, at least in the next couple of weeks, i don't have any plans for OS 10 support.

Mi idea isn't just open the eSpaces in SS10 and publish. I plan to check for a new plugin version or new features and include them (if any) in this OS integration. As you can imagine this is a lot more time consuming...


Best regards

It isn't difficult to upgrade to P10 and use the new functionalities of the platform, one thing that can be changed is the dependence  from ardoJSON, now the platform have built in JSON objects other thing you can do is remove the unused objects and the upgrade to the latest version of ztree is not difficult either.

I've uploaded my P10 version.

Tiago Flor wrote:

It isn't difficult to upgrade to P10 and use the new functionalities of the platform, one thing that can be changed is the dependence  from ardoJSON, now the platform have built in JSON objects other thing you can do is remove the unused objects and the upgrade to the latest version of ztree is not difficult either.

I've uploaded my P10 version.


Hello Tiago, first of all let me thank you for wake me up! I have already forgotten about ztree update to OS10... shame on me   !

And you are wright, isn't difficult but it's a little time consuming, especially checking all the examples to see if they still work in the new version.

Thanks also for pointing out that OS10 has built in JSON functions that can replace the ones in ardoJSON. About this, in your version did you check if the examples page was working? I ask this because when i replace the ardoJSON functions with the built in ones the examples stop working! I had to make a few "corrections" to the JSON string returned by the function namely remove the text "ztreeData:" and replace the double brackets with a single bracket. Did you have the same problem? If so you do you solve it?


Anyway, i already done all the changes (i hope) and i'm in the checking the examples step, so in the next few days there will be news, probably   .


Best regards




The replacement of the ardojson for the built in JSON functions gives a little work because it is necessary to redefine the variables (ex.: change the ztreeData parameter from ztreeData Record List to ztreeData List). 

I have checked the examples page and yes they work, you can see it for yourself in: zTreeExample

Also if you are going to update to the latest version of the ztree make sure you add all the source code if you use the ztree core file you have to add the code in exHideNodes (the creator possibly forgotten it :) )


Hey guys, have you already tested it? I use the component in one of my applications, and after the automatic upgrade on Personal Environment to P10, the component still works perfectly with no extra effort... ;)

Yes, a simple upgrade to P10 should work however, the objective is also to upgrade the ztree version and use the new native functionalities of P10, that upgrades give a little work, they are not difficult but they consume some time to do.

It's out!!!

I just uploaded a P10 Ztree version   .

The tests went ok and i don't found any problems.

I'm still not a very proficient P10 user so if you people find some possible improvement please let me know.


Many thanks to Tiago Flor for waking me up and for it's very useful tips   .