Fail to start outsystems service under Linux Centos 6.7 x64

Fail to start outsystems service under Linux Centos 6.7 x64

  

Last week we just finished the installation of outsystem under linux centos 6.7 x64 along with outsystem 10 + wildfly 8.2.0 + oracle 11gr2.

However since it is a development machine, it is not running 24/7.
 
I have question about the service especially about the script which should I run in order to make Outsystems running after the linux boot up.
 
I have tried to invoke this command manually:
/etc/init.d/outsystems start scheduler
/etc/init.d/outsystems start logserver
/etc/init.d/outsystems start deployer
/etc/init.d/outsystems start controller
/etc/init.d/outsystems start rmi

 
[root@outsysppu ~]# service outsystems status
RMI Registry Service - RUNNING
OutSystems Deployment Controller Service - RUNNING
OutSystems Deployment Service - RUNNING
OutSystems Log Service - RUNNING
OutSystems Scheduler Service - RUNNING



I found out all of the service running but I cannot access Service Center, is there something I miss??

Thank you in advanced

If it's not on auto-start, you should probably also bring up the wildfly-outsystems service.

service wildfly-outsystems start


Additional note, the RMI server should be started before all the other services. If you just do service outsystems start, you will start all the outsystems services (not wildfly) in the correct order. Any particular reason for you to be starting them one by one on your own ?

Hi Ricardo, thank you for your response.

it is really makes sense if outsystems is not working since I start it in wrong order. I will try to fix the order tomorrow.


Any particular reason for you to be starting them one by one on your own ?
>> actually I just follow what's written on /opt/outsystems/platform/configurationtool.sh and I found out they are start one by one, so I tought it is the correct way x_x

Hi Ricardo,

I have tried to start outsystem in following ways now:
<<starting oracle db service>>
service outsystems start
service wildfly-outsystems start
service wildfly-outsystems-mq start


it looks like the service working good now
[root@outsysppu ~]# service outsystems status
RMI Registry Service - RUNNING
OutSystems Deployment Controller Service - RUNNING
OutSystems Deployment Service - RUNNING
OutSystems Log Service - RUNNING
OutSystems Scheduler Service - RUNNING
[root@outsysppu ~]# service wildfly-outsystems status
wildfly-outsystems is running (pid 15621)
[root@outsysppu ~]# service wildfly-outsystems-mq status
wildfly-outsystems-mq is running (pid 16849)


but when accessing http://192.168.10.145/ServiceCenter/, it still shows Unable to connect


it is so confusing, I cannot find out whats wrong with it   

Solution

I imagine that is happening because  you don't have iptables enabled. OutSystems uses iptables to redirect from port 80, a reserved port which only root can bind to, to port 8080 which is the port we use to actually bind the listener.

You should do "chkconfig iptables on" and run configuration tool to ensure iptables is up and running.

Are you following the Installation Checklist to perform the installation?

Solution

Ricardo Silva wrote:

I imagine that is happening because  you don't have iptables enabled. OutSystems uses iptables to redirect from port 80, a reserved port which only root can bind to, to port 8080 which is the port we use to actually bind the listener.

You should do "chkconfig iptables on" and run configuration tool to ensure iptables is up and running.

Are you following the Installation Checklist to perform the installation?

Hello...
sorry I fell sick and have to stay in bed for 4 days.

Are you following the Installation Checklist to perform the installation?
>> I did

I did invoke chkconfig iptables on, but there's no luck...

it still the same, cannot access ServiceCenter x_x

btw, I dont have to put a script to redirect 8080 to 80 and 8443 to 443 right?
since I did not install other firewall on the linux box

*******

oh ya, if I invoke /opt/outsystems/platform/configurationtool.sh
I could access ServiceCenter.

now I tried to stop the outsystems & wildfly service, then start the outsystems & wildfly service once again
it works...
I could access ServiceCenter


but if I tried to reboot the machine, then start the outsystems & wildfly service once again
I cannot access ServiceCenter once again T__T


it is so strange x_x


Dear Ricardo,


thank you for your assistance, seems like it is working good now.

you were right, I was disable linux firewall which makes iptables service does not work.


and also one stupid mistake, the IP address i used for outsystems was also userd by another system which makes the collision and the connection working wrong.


now it is working.


thank you so much.