Can't get accordion to work... help please!

Can't get accordion to work... help please!

  

I fairly new to Outsystems and this will hopefully be a dumb/ easy question to answer. 


But for some reason I can't get the Accordion function to work properly. Basically I just cant get the expand/ collapse to function as it should.


Can someone point me in the right direction? 


OML attached. 

Hi Talis,

Use "SectionExpandable". This will do the behavior you need.


Greetings,


Niels

Niels Favreau wrote:

Hi Talis,

Use "SectionExpandable". This will do the behavior you need.


Greetings,


Niels


Hi Niels,


Thanks for the feedback, however I get exactly the same behavior, it's just held open, it cannot be collapsed. 

Talis Krumins wrote:

Niels Favreau wrote:

Hi Talis,

Use "SectionExpandable". This will do the behavior you need.


Greetings,


Niels


Hi Niels,


Thanks for the feedback, however I get exactly the same behavior, it's just held open, it cannot be collapsed. 

Are they designed to work with the London theme? 

Helo Talis,

Looking at your OML, I think I know what your problem is: you have an AccordionItem widget all by itself. The correct way to use the Accordion is to first drop an "Accordion" widget on your form, and then add "AccordionItems" to it.

I'm attaching the corrected OML to this post. Be aware though that I wasn't able to test it, because it references an "Employees" module that I don't have.

Talis Krumins wrote:

I fairly new to Outsystems and this will hopefully be a dumb/ easy question to answer. 


But for some reason I can't get the Accordion function to work properly. Basically I just cant get the expand/ collapse to function as it should.


Can someone point me in the right direction? 


OML attached. 


Hi Talis,


I cannot open your oml since I'm on an older version of outsystems. If you are not using Silk UI theme, then in the container that contains the accordion, then in the extended properties of the container, set "class" property to value 'GetCssGlobalContext()', without quotes and make sure that the page contains JSWidgetsForLayout of SilkUI. 

Hi Aurelio and Gurvinder,


I tried both of your advise and for some reason I still couldn't get things to function. Instead I've migrated my themes over to Dublin and this has resolved my issue. I was hoping things would work for the completeness of this thread, but I just don't know why things weren't working. But in any case I've worked out a way around it. 


Thanks again!