OS10 mobile Adaptive\MasterDetail widget ids issue

OS10 mobile Adaptive\MasterDetail widget ids issue

  

Hi,


Recently I've been developing a simple mobile app with the objective of searching and displaying contents of a db. The approach is very simple. One screen to input filter parameters and one screen to show results.

To show this results I'm using this Adaptive\MasterDetail, which is giving me some trouble.

As part of the widget, when I click an item on the list, it correctly navigates to the screen with the info but there is no way to distinguish which item I clicked as the id associate with the widget doesn't have anything to do with the results from the aggregate..


Any tips?

Regards,

Eduardo

Hi Eduardo,

Your printscreens are not available (broken links), could you please make your print screens available?


Here is one.

Heres the other.


Thanks for the reply Daniel.

Hi Eduardo,

Can you tell me if your problem was solved, and what the solution was, because I have the same problem.

Hi Eduardo and Jan,


I believe that Eduardo problem was in the variable of the expr.PNG, he was making use of the Current of the Query (GetLCWithDept... ) instead of usign the variable of TableRecord.


Hope it helps you both.

Hi Daniel,

That is the problem, I can't see my table at the entities in the expression value dialog. Is there maybe a master class/webinar on how to use the MasterDetail widget. Because the function of the client action "MasterDetailItemSelected" is not explaned anywhere.