Cannot read property 'List' of undefined

Cannot read property 'List' of undefined

  

Hi,

I get the following Error while fetching data in my App. 

"Cannot read property 'List' of undefined"

Can anyone tell me what i do wrong?

regards

Arnold




Hey Arnold,


can you please provide a bit more context? Is this a mobile app or a web app? Which OutSystems version are you using? Which stack? Which database?

Hi,

I'm using V10 and building a mobile App

I use a static Entity with a extra numeric Field. 

When  I changed the value of this field , an error will raise in my app on the pages where this entity is used in a aggregate.





Hi, I encountered same problem...

Any solution?

Thanks.

Hello guys, I'll try to get some help to you. Are you able to reproduce the behavior in a small espace? It would really ease the debugging process...

Hi Pedro,

Thanks for helping...

Below is my error screen, and for some reasons, even after logon, all logged-user related screen have problems with many javascript error. I cannot even see the User Block anymore (which I have modified to show photo and Username).

I then remembered when I was trained by Jorge @Singapore, he told my friend who is having strange problem to clone his module.

I tried to clone my problematic module, and voila!
The cloned module works perfectly...

Any ideas?

I'm currently requesting permission to share my espace/environment to you for debugging...

Thanks,
Harlin.


Even before login have this error:


User Block empty:

My user account screen:

Log file:

Message:Cannot read property 'List' of undefined
Environment InformationeSpaceVer: 158 (Id=378, PubId=372, CompiledWith=10.0.105.0)
RequestUrl: XXXXXXXXXXXXXXXXXXXXXXXXX (Method: POST)
AppDomain: /LM/W3SVC/22/ROOT/EPTMobile-299-131256653989161804
FilePath: C:\OutSystems\Sandboxes\IOA8LA019\Platform Server\running\EPTMobile\
ClientIp: 125.161.11.194
Locale: en-US
DateFormat: yyyy-MM-dd
PID: 46016 ('w3wp', Started='11/5/2016 5:01:35 PM', Priv=1471Mb, Virt=19359Mb)
TID: 24
Thread Name:
.NET: 4.0.30319.42000
Client-Side Log
Stack:TypeError: Cannot read property 'List' of undefined
    at Function.t.dataFromJS (https://XXXXXXXXXXXXXXXXX/scripts/OutSystems.js?z3_tJEwz5c89f9g+YujDjQ:4:28041)
    at Function.t.fromJS (https://XXXXXXXXXXXXXX/scripts/OutSystems.js?z3_tJEwz5c89f9g+YujDjQ:4:28290)
    at Function.fromJS (eval at t.init (https://XXXXXXXXXXXXXXXXXXX/scripts/OutSystems.js?z3_tJEwz5c89f9g+YujDjQ:4:16205), <anonymous>:7:66)
    at GetEPTUserByIdAggrRec.t.fromJS (https://XXXXXXXXXXXXX/scripts/OutSystems.js?z3_tJEwz5c89f9g+YujDjQ:9:18861)
    at https://XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX.Common.UserInfo.controller.js?1Y_u5QxlyiX4YPD2tYQ3Tg:17:36
    at https://XXXXXXXXXXXXXXXXXXXXXXXXXXX/scripts/OutSystems.js?z3_tJEwz5c89f9g+YujDjQ:9:6233


Message:Cannot read property 'content' of undefined
Environment InformationeSpaceVer: 158 (Id=378, PubId=372, CompiledWith=10.0.105.0)
RequestUrl: XXXXXXXXXXXXXXXXXXXXXX (Method: POST)
AppDomain: /LM/W3SVC/22/ROOT/EPTMobile-299-131256653989161804
FilePath: C:\OutSystems\Sandboxes\IOA8LA019\Platform Server\running\EPTMobile\
ClientIp: 125.161.11.194
Locale: en-US
DateFormat: yyyy-MM-dd
PID: 46016 ('w3wp', Started='11/5/2016 5:01:35 PM', Priv=1444Mb, Virt=19338Mb)
TID: 63
Thread Name:
.NET: 4.0.30319.42000
Client-Side Log
Stack:TypeError: Cannot read property 'content' of undefined
    at Object.ht [as jsToBasicType] (https://XXXXXXXXXXXXXXXX/scripts/OutSystems.js?z3_tJEwz5c89f9g+YujDjQ:5:23623)
    at https://XXXXXXXXXXXXXXX/scripts/EPTMobile.MainFlow.UserAccount.controller.js?1fQUIECP6P+3T91QD48Ggg:54:111

Cool, thanks for the info. I'll try to look at it.

Hi Pedro,

Now I have already cloned this module 3 times because this problem keep appearing...

More update...

My module starts showing this problem again, but this time I did not clone it.

Like you notice from my previous post, Common/UserInfo block inside Common/Menu block is empty when error appears.

I curiously delete Common/UserInfo block inside Common/Menu block, and voila no error!

I hope this info will help you fixing this Javascript problem.

Hello again,

so I was able to talk with some people and I've been told that this issue is already solved. Are you able to upgrade your infrastructure?

Hi Pedro,

Yes our Partner Cloud platform version is 10.0.105.0.

I have already open support ticket to request upgrade to latest version.

Thank you very much.

Has anyone managed to solve the problem? I encountered this same error in a new application

Rôney Rocha wrote:

Has anyone managed to solve the problem? I encountered this same error in a new application

Which platform version? If I recall it was a bug that was fixed with 10.0.200.0 platform version.