Strange problem with url in browser not matching the page i'm on 

Strange problem with url in browser not matching the page i'm on 

  

This is a strange problem I cannot get a hold on to fix .. :-) 

I have a list page, clicking on a link shows a page where I can change a date and commit and it returns to the list page. Now the following funny thing happens, the list page is displayed, but the url in the browser still shows the edit page url. I have other list/edit combinations in the app but they do not show this behaviour. The button I click in the edit page is a commit server side butten, so no strange things here. I just update a record and do a redirect to another form. Anyone have a clue how to fix it ? 

(platform 9.1 and we are running in a Azure cloud)


Regards,

Wim

Wim van den Brink wrote:

This is a strange problem I cannot get a hold on to fix .. :-) 

I have a list page, clicking on a link shows a page where I can change a date and commit and it returns to the list page. Now the following funny thing happens, the list page is displayed, but the url in the browser still shows the edit page url. I have other list/edit combinations in the app but they do not show this behaviour. The button I click in the edit page is a commit server side butten, so no strange things here. I just update a record and do a redirect to another form. Anyone have a clue how to fix it ? 

(platform 9.1 and we are running in a Azure cloud)


Regards,

Wim

Hi Wim,

This behavior is happening because the redirect happens on the Server (similar to Server.Transfer() of ASP.NET). One easy way to resolve this is to change the Submit Method of the Action to Ajax Submit from the properties of your link/button or to use Navigate. 

You can view more discussion about this topic at this link: https://www.outsystems.com/forums/discussion/6756/refresh-url-address-from-action-screen/


Regards,

Gurvinder