Feedback_AjaxWait Widget - Requirements ?

Feedback_AjaxWait Widget - Requirements ?

  

Hi Guys


In order to use Feedback_AjaxWait Widget to lock the entire screen when my page is loading what is it that I need ? Do I also need to change my submit Link's method to "Ajax Submit"

Gontse Ntshegi wrote:

Hi Guys


In order to use Feedback_AjaxWait Widget to lock the entire screen when my page is loading what is it that I need ? Do I also need to change my submit Link's method to "Ajax Submit"

Hi Gontse,


All you need to do is add the Feedback_AjaxWait widget to your screen and change the submit type of your action to "Ajax Submit".


Regards,

Gurvinder


Hi Gurvinder


I did that but when I change my submit type of my action to "Ajax Submit" it does not do anything. Only when I change it to "Submit" it goes through another page.

Gontse Ntshegi wrote:

Hi Gurvinder


I did that but when I change my submit type of my action to "Ajax Submit" it does not do anything. Only when I change it to "Submit" it goes through another page.

Can you post an oml of what you are doing so that I can check what is wrong. 

I have attached a sample oml here which shows a simple example of Ajax Submit. It contains AjaxWait widget in the footer as well, which should answer your another question(http://www.outsystems.com/forums/discussion/20471/button-method/?utm_source=community&utm_medium=email&utm_campaign=forum-reply=#Post79956) of where to put the AjaxWait.

Hi


I see where the problem is. My custom layout doesnt have a footer. So If I dont have a footer Ajax submit dont work ?

Gontse Ntshegi wrote:

Hi


I see where the problem is. My custom layout doesnt have a footer. So If I dont have a footer Ajax submit dont work ?

Hi,

No, not having a footer should not make any difference. I placed it in footer only because it is always a good idea to put things like these at the bottom of page for better page loading.


Gontse Ntshegi wrote:

Hi


I see where the problem is. My custom layout doesnt have a footer. So If I dont have a footer Ajax submit dont work ?

Did you try setting a debugger to check if your request goes to your action when you use Ajax Submit? Use debugger to step through your logic, it might be that there's something else that is causing issues.