[Event System] Getting initialization error in Java stack

[Event System] Getting initialization error in Java stack

  
Forge Component
(19)
Published on 1 Nov by Leonardo Fernandes
19 votes
Published on 1 Nov by Leonardo Fernandes

I have been using Event Systems for Java Stack for some time and only recently (after upgrading to platform 10) started having an issue in which it appears java cannot initialize something in the extension. When I try to call the "Invoke" action, I get a java.lang.ExceptionInInitializerError. For all subsequent calls to that "Invoke" action, I get an error message that reads, "Could not initialize class outsystems.noseventsystem.events.sideeffects.FinishRequestInterceptor."

I am not sure if it is an issue with the component, or something is wrong with my platform environment. I have contacted OS to get more information on the latter. Has anyone experienced this before?

Hi Grayson, thanks for your contact.

This is surely not an OutSystems problem. I haven't tested Event System for P10 on Java - not yet! So I would like to ask if you could wait a few more days, until I can reproduce your problem (it should be easy) and fix it.

Thank you for your quick reply! I look forward to hearing back from you.

Hey Leonardo, any updates on this? If you want to connect with me offline I could possibly help in resolving the issue.

Hi Grayson. Sorry for the delay, but the Event System is already working in Java.

If you have any problems, please let me know.