Utilities\SwipeEvents not working

Utilities\SwipeEvents not working

  

Hi,

I've tried to implement swipes in my mobile app, but Utilities\SwipeEvents seems not working at all. I have a named image within named container and Utilities\SwipeEvents points to that id (I've tried both image and enclosing container) and attache event (alert for test), but nothing seems to happen in the app. and if page is long then it just scrolls... none of swipes are triggered... 

Is there anything more I should set up?


PS: default swipe from left edge is working - shows Side menu. I was testing in iOS on device.


Thank you for any hint.

Solution

Hi Mykola,

Make sure your SwipeEvents widget is placed after the target widget. Otherwise it won't work.

Solution

Hi Aurelio,

That made the trick!   Thank you a lot. 

It also seems it should be placed immediately after target widget, isn't it?

Glad I could help Mykola.

I tried putting the SwipeEvents at the very bottom of the screen, and it still worked. So apparently, as long as it's after the target widget, it doesn't really matter where it is.