Phone Mobile app v10 content block disappear

Phone Mobile app v10 content block disappear

  

Hi,

For the second time I've encounter a strange bug that some styles or local storage logic of inner elements can make content block not visible. The html is there and no styles seems to be changed, but block is not displayed. There is script on the page source:

<script style="display: flex; width: 100%; height: 0px;"></script>

I will appreciate any hint of why this is happening how to avoid it?

Thank you.

Hi Mykola,

Can you share a screenshot of the problem? Where is that block placed? Inside a list?

Btw that script belongs to the list widget.

Hi João,

I can't make a screenshot right now as I've already removed this screen. I've created new screen and added same elements and it is working ok... I will try to catch the error cause if it will appear again.

Hi João,

I guess I've found the problem that seems  to be a bug - the content is become not visible if I set aligning for Layout web block... 




also if I use align option for container it can only be undone with "undo" as clicking on enabled align option do not unselect it - so once clicked you can only change what alignment you want and can't revert to "none enabled" state.

I think this is not a proper behavior and would be cool if it will be fixed in next updates.


Cheers,

Nick 

 


Solution

Mykola regarding the alignment of Layout web-block the problem is that once you put a container around the the Layout you have to set the height of the container. If use Chrome to inspect the page structure you'll see the container has height 0.

To revert the container's alignment you can always go to the container properties and set the alignment property to none.


Solution

Hi João, 

Thank you for clarifications. Now it is clear that is not a bug :) 


Cheers,

Nick